summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-panels/sphinx-panels-0.6.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-09 22:25:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-09 22:25:44 +0100
commit796e724b5ace96ff70d918765662edf62f1d8c85 (patch)
treeb09742996db0de2a2414587542b1b91d4ae5c522 /dev-python/sphinx-panels/sphinx-panels-0.6.0-r1.ebuild
parentcd7ab3ad114e9777d85ced67abdd5b25d0bd4efe (diff)
gentoo auto-resync : 09:07:2023 - 22:25:43
Diffstat (limited to 'dev-python/sphinx-panels/sphinx-panels-0.6.0-r1.ebuild')
-rw-r--r--dev-python/sphinx-panels/sphinx-panels-0.6.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/sphinx-panels/sphinx-panels-0.6.0-r1.ebuild b/dev-python/sphinx-panels/sphinx-panels-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..20998bfad1ce
--- /dev/null
+++ b/dev-python/sphinx-panels/sphinx-panels-0.6.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="A sphinx extension for creating panels in a grid layout"
+HOMEPAGE="https://github.com/executablebooks/sphinx-panels"
+SRC_URI="https://github.com/executablebooks/sphinx-panels/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+BDEPEND="test? ( dev-python/pytest-regressions[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme