summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-notfound-page
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-14 13:40:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-14 13:40:00 +0100
commit3e627c1432765cb6a32877e73f985e8bfb5102ce (patch)
treee4d7919d9e1ca0a54c1a3758c86555d6e9121956 /dev-python/sphinx-notfound-page
parent4a30f472147c2d8642bd558b78fcfce7b6a9c6b9 (diff)
gentoo auto-resync : 14:07:2022 - 13:40:00
Diffstat (limited to 'dev-python/sphinx-notfound-page')
-rw-r--r--dev-python/sphinx-notfound-page/Manifest2
-rw-r--r--dev-python/sphinx-notfound-page/sphinx-notfound-page-0.8.3.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sphinx-notfound-page/Manifest b/dev-python/sphinx-notfound-page/Manifest
index 461a7e29a4ce..6e28e924d31a 100644
--- a/dev-python/sphinx-notfound-page/Manifest
+++ b/dev-python/sphinx-notfound-page/Manifest
@@ -1,3 +1,5 @@
+DIST sphinx-notfound-page-0.8.3.gh.tar.gz 59219 BLAKE2B cdb95906dba4d51aee88b220f094204575f2800737f160c7c028033002d41d2c793a91e1c61101f7c7c960ddf3b4d2ef83fbd285dd73ff5aed6c6c933b1fc1e7 SHA512 8d43ccfd3f83ff25b7a20ee3f5352489092dc641b4a794199c06c0971078a132a42b05c85588508ec38487f2915eedec98c2deac02d6c4576828be2fbc7f13b0
DIST sphinx-notfound-page-0.8.gh.tar.gz 57650 BLAKE2B e57634ba9a7faf81e6ee8d9b082d96742b580606f2e2fd559842049ba2e80bcb44bb6bd7a9c7eed6038e4c3ddb0416e32fceb4d47a72b8a600443e0020ff33d6 SHA512 eeb5b8da24ecb8f9814540a126f08204ae623705068608c2ee32a4f90303bdaab5f3934bdc36dd06dff047beb0225603f8cfc9b736769836385837047a36a674
+EBUILD sphinx-notfound-page-0.8.3.ebuild 851 BLAKE2B 61b2f12016a962a34246d9f5aff01990eaa63860b15662e4784972eb3a402f28a116ad2172d9c96e9a8df341396764bd8bbb27e1a64a889f103802ec6434073c SHA512 8ae791ee7566315326bd5e4551111eac5b9f868e2d80cc8ee0ac2615b8a4cfacdc13b0cd9c8e7c764f264880cbdb1153604b454dd0b8789c4a18bb11d72fc010
EBUILD sphinx-notfound-page-0.8.ebuild 684 BLAKE2B 196fc0767066e1dfe51ef8f66665f746901b606bde13a8952bc72c93403d1ecc09cfe68c195fe535b6b5ca859a9d11168e8f8ca2a010df753c546bcf698aa5f0 SHA512 8b06394539060cf62c182575cacf281010c05ddae56cb54cf5ca9eecec64c561bdda1509e1ca39c2d66eb557d0d050a555bd1dea3bb3029f5b9af6bbcd453ac3
MISC metadata.xml 651 BLAKE2B 7b4c1c58782b6a1e6118744d4933d8bfc1391fef578350f9622dddfb911a4319be8fc2cd2a297d5ac84bb97249d520a1cb740ed00d6314cb3cbf1dce5c119dfd SHA512 4b531fde722c6f0f0709405669efe61cfe2fd14e52f627ee67001b81d5268444b226630f55c6dc6a149ea86699379289368826429754abbad6cdaf36f1f4a673
diff --git a/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.8.3.ebuild b/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.8.3.ebuild
new file mode 100644
index 000000000000..4d240a8aa65b
--- /dev/null
+++ b/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.8.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Create a custom 404 page with absolute URLs hardcoded"
+HOMEPAGE="
+ https://sphinx-notfound-page.readthedocs.io/
+ https://github.com/readthedocs/sphinx-notfound-page/
+ https://pypi.org/project/sphinx-notfound-page/
+"
+SRC_URI="
+ https://github.com/readthedocs/sphinx-notfound-page/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # calls sphinx-build directly, works around venv
+ tests/test_urls.py::test_parallel_build
+)