summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.8.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-14 13:40:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-14 13:40:00 +0100
commit3e627c1432765cb6a32877e73f985e8bfb5102ce (patch)
treee4d7919d9e1ca0a54c1a3758c86555d6e9121956 /dev-python/sphinx-notfound-page/sphinx-notfound-page-0.8.3.ebuild
parent4a30f472147c2d8642bd558b78fcfce7b6a9c6b9 (diff)
gentoo auto-resync : 14:07:2022 - 13:40:00
Diffstat (limited to 'dev-python/sphinx-notfound-page/sphinx-notfound-page-0.8.3.ebuild')
-rw-r--r--dev-python/sphinx-notfound-page/sphinx-notfound-page-0.8.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.8.3.ebuild b/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.8.3.ebuild
new file mode 100644
index 000000000000..4d240a8aa65b
--- /dev/null
+++ b/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.8.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Create a custom 404 page with absolute URLs hardcoded"
+HOMEPAGE="
+ https://sphinx-notfound-page.readthedocs.io/
+ https://github.com/readthedocs/sphinx-notfound-page/
+ https://pypi.org/project/sphinx-notfound-page/
+"
+SRC_URI="
+ https://github.com/readthedocs/sphinx-notfound-page/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # calls sphinx-build directly, works around venv
+ tests/test_urls.py::test_parallel_build
+)