summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-basic-ng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-09 10:24:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-09 10:24:33 +0100
commitca85c13c0f9c4f9af191bc9a46a7bc274e1d25bf (patch)
treeabdc3a1a0b92472802acf004b02b8706b10ba2ea /dev-python/sphinx-basic-ng
parent49307b439ea0ae14beb0772de83e70297ae8356c (diff)
gentoo auto-resync : 09:07:2023 - 10:24:32
Diffstat (limited to 'dev-python/sphinx-basic-ng')
-rw-r--r--dev-python/sphinx-basic-ng/Manifest2
-rw-r--r--dev-python/sphinx-basic-ng/sphinx-basic-ng-1.0.0_beta2.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/sphinx-basic-ng/Manifest b/dev-python/sphinx-basic-ng/Manifest
index 937c84ec7310..5f580325268d 100644
--- a/dev-python/sphinx-basic-ng/Manifest
+++ b/dev-python/sphinx-basic-ng/Manifest
@@ -1,3 +1,5 @@
DIST sphinx-basic-ng-1.0.0.beta1.gh.tar.gz 24059 BLAKE2B 319f27b7326acf0ad1457fcb4d9b6257fb420eaf2bf7d4ebd6e9333f992bc5d0a5fdb518f196edc342c023f3a1c9d1258de2bac5f263d35226ac3ed62d747f23 SHA512 177da348fdb2af88bbe3a269f0d468f4d8cd5710a3102ea0fdd943505bc5251a73783a12e5397750fd7bec2df7ecce6601e82a95e777cbd40540a7833982c998
+DIST sphinx-basic-ng-1.0.0.beta2.gh.tar.gz 24076 BLAKE2B ce2d8e20d22e4d4e62b4db2eed41c72329a076bbacbf4cd247b657404e8b7f714c37b9625d77363edf7d4e53d9cef45568c53cbad8275bd7b519c0f7b1657c1f SHA512 e8c342251d0b0a085a1cd3a8fe8bede90cde3c5a404daf7afc24b601e6bdcef1c37161fadd21d34306633f1978bc96438bad3d9aa4511913dd92d69f4e299926
EBUILD sphinx-basic-ng-1.0.0_beta1.ebuild 892 BLAKE2B e042d436d5179632419c53b93a369916638d5f41881e962599cfcadd8a8d6508194f15a8427f40d1a93abd42ab05843d71a25cb050a21ef1dea92510f342ed47 SHA512 e2ff1dbd3ec0fb500e0cc1ee0047787f131e735f3c3533052c82251879ef11d52472c6943fbdb4c40d164b5d9b7f5a72656f156c8f9c10fc6f30cd32c009a980
+EBUILD sphinx-basic-ng-1.0.0_beta2.ebuild 900 BLAKE2B 2374f6c972fa21b3cc55492583e9e117112cf0e492a8ff11b4117e1e0bb7ca22acc6f489eaf085e36c26fa74aefad771291398331d86b11473de8051e27a490f SHA512 8ca2078d2f718fde064bec247b1844c3d274fe386627ecbac33c5547ab52f901d90e7360e8d3af41af0424e0372d793cf8749eb907ae409adc7d2e630eb8e37f
MISC metadata.xml 362 BLAKE2B a93dc662c8ab618397c8d0504342e8f1bd74226b131ea4ca07771cdeb75eb8947451b4353c0da16760f07f935ebb75adcdef4f189ff39e0cf707d03e8fa319e2 SHA512 fb27130b3fcff9043b3ad33e34c92f638cae46d526dcbe77cfe088abf80e6b89992edb1e0b571a5a2447bc6c8ba31ae84776d153067a33b5d6d14326149e7f46
diff --git a/dev-python/sphinx-basic-ng/sphinx-basic-ng-1.0.0_beta2.ebuild b/dev-python/sphinx-basic-ng/sphinx-basic-ng-1.0.0_beta2.ebuild
new file mode 100644
index 000000000000..86839c93bdc0
--- /dev/null
+++ b/dev-python/sphinx-basic-ng/sphinx-basic-ng-1.0.0_beta2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${P/_/.}
+DESCRIPTION="A modern skeleton for Sphinx themes"
+HOMEPAGE="
+ https://github.com/pradyunsg/sphinx-basic-ng/
+ https://pypi.org/project/sphinx-basic-ng/
+"
+SRC_URI="
+ https://github.com/pradyunsg/sphinx-basic-ng/archive/${PV/_/.}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/sphinx-4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ local HTML_DOCS=()
+ build_sphinx tests/barebones
+ rm -r tests/barebones/_build || die
+}