summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-basic-ng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-02 21:08:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-02 21:08:25 +0000
commitc107831b9ebfe892c139cdb68d747eea369d8588 (patch)
tree3e2fbc0ea06bf0ea7a5fdf0250036433cd4bc11f /dev-python/sphinx-basic-ng
parent52895d302231ef73b105756d2781b2262638d566 (diff)
gentoo auto-resync : 02:02:2023 - 21:08:25
Diffstat (limited to 'dev-python/sphinx-basic-ng')
-rw-r--r--dev-python/sphinx-basic-ng/Manifest2
-rw-r--r--dev-python/sphinx-basic-ng/sphinx-basic-ng-1.0.0_beta1.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/sphinx-basic-ng/Manifest b/dev-python/sphinx-basic-ng/Manifest
index 27c594a02f75..980d75e8824d 100644
--- a/dev-python/sphinx-basic-ng/Manifest
+++ b/dev-python/sphinx-basic-ng/Manifest
@@ -1,3 +1,5 @@
DIST sphinx-basic-ng-0.0.1.a12.gh.tar.gz 23821 BLAKE2B 905186227d725d6f62c0f4c5b4df49ada8817dd44a4000b23b62e60ce5ca3bef4a4046c9543a07a7b0cc0c12dd5278dc783633324fbe113cf453ee540fa97ff7 SHA512 6df9445306b27ae4b29b338773fa4adcee631b4be04fdde674855dfcb683f7cf7ad3c40124c85353608b63523738b6bc83c6c4f4b2b212cafa41d38462ffcac4
+DIST sphinx-basic-ng-1.0.0.beta1.gh.tar.gz 24059 BLAKE2B 319f27b7326acf0ad1457fcb4d9b6257fb420eaf2bf7d4ebd6e9333f992bc5d0a5fdb518f196edc342c023f3a1c9d1258de2bac5f263d35226ac3ed62d747f23 SHA512 177da348fdb2af88bbe3a269f0d468f4d8cd5710a3102ea0fdd943505bc5251a73783a12e5397750fd7bec2df7ecce6601e82a95e777cbd40540a7833982c998
EBUILD sphinx-basic-ng-0.0.1_alpha12.ebuild 943 BLAKE2B c478a8e9dfd73406049e0e887f5e9e1a23000f33000002d0eb57521e8d8f7b1d88b06625fd2859be330cf329860b8d49c374ba87a6abb389654f1322e5303945 SHA512 7fcf135432386ecec233f4e7ca2b82eff1e3ff146df60fe332a69d64ec2bbb9f069dd2cab4dd9017b78d933d0a003833d3de6f560e37fd309ee503bc57395a06
+EBUILD sphinx-basic-ng-1.0.0_beta1.ebuild 899 BLAKE2B 1f89819898459d1a48d2837ebae7edd4ce46f0588280e7c71695e25263fbf921d4d7bee35bda51d626427f2062e41ef5556748bd678c9064e2129266e9af2308 SHA512 a69a5f0be87fa4af42865443282ba99613f0aa1e16ab2711e13b572be2a651deb723fe6bf0221c19ea4e48e157222179487db3f723382227982eafa90d1fe036
MISC metadata.xml 362 BLAKE2B a93dc662c8ab618397c8d0504342e8f1bd74226b131ea4ca07771cdeb75eb8947451b4353c0da16760f07f935ebb75adcdef4f189ff39e0cf707d03e8fa319e2 SHA512 fb27130b3fcff9043b3ad33e34c92f638cae46d526dcbe77cfe088abf80e6b89992edb1e0b571a5a2447bc6c8ba31ae84776d153067a33b5d6d14326149e7f46
diff --git a/dev-python/sphinx-basic-ng/sphinx-basic-ng-1.0.0_beta1.ebuild b/dev-python/sphinx-basic-ng/sphinx-basic-ng-1.0.0_beta1.ebuild
new file mode 100644
index 000000000000..b3a5b5209fe0
--- /dev/null
+++ b/dev-python/sphinx-basic-ng/sphinx-basic-ng-1.0.0_beta1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_/.}
+DESCRIPTION="A modern skeleton for Sphinx themes"
+HOMEPAGE="
+ https://github.com/pradyunsg/sphinx-basic-ng/
+ https://pypi.org/project/sphinx-basic-ng/
+"
+SRC_URI="
+ https://github.com/pradyunsg/sphinx-basic-ng/archive/${PV/_/.}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/sphinx-4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/myst_parser[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ local HTML_DOCS=()
+ build_sphinx tests/barebones
+ rm -r tests/barebones/_build || die
+}