summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-autoapi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-25 00:07:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-25 00:07:14 +0100
commitf8999218b5a6eafa151e7367030cbfdb69e045ed (patch)
tree0d0e9293bcb75153cd18542369fa789ede9338a0 /dev-python/sphinx-autoapi
parentaa4954f71a3ba2293395a8cce2321a70c39c7554 (diff)
gentoo auto-resync : 25:05:2024 - 00:07:14
Diffstat (limited to 'dev-python/sphinx-autoapi')
-rw-r--r--dev-python/sphinx-autoapi/Manifest2
-rw-r--r--dev-python/sphinx-autoapi/sphinx-autoapi-3.1.1.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/sphinx-autoapi/Manifest b/dev-python/sphinx-autoapi/Manifest
index 8246c6b46b39..32c8eb0b94d0 100644
--- a/dev-python/sphinx-autoapi/Manifest
+++ b/dev-python/sphinx-autoapi/Manifest
@@ -1,5 +1,7 @@
DIST sphinx-autoapi-3.0.0.gh.tar.gz 62951 BLAKE2B 80c1168b7d6f2d8489139d1daaa00817bf88345b92d962d1b7114ffd078dab5babd00f3837b9a80bd7175f07a50a432be4096140ac3ee8db11d90e1b836cd308 SHA512 fece7ff76de1ad4a58d8128d7c1f4c57a91ffbc2fb788f7bf4ce230860e97279f8ddf32d24dee4b961d89807056abd2f621484ff91e13b98b57d7f7a00d1cd4c
DIST sphinx-autoapi-3.1.0.gh.tar.gz 67664 BLAKE2B 5fefd1cf5ff401db9e309eeed3d8211bd72e43d6f40b088b6e1a2e406a910b2b99ff0e2431d0f8c55b0300c51f65c6892f2068131ecea2524fba3f0dd439bd2b SHA512 22ea54a11d9ecb2a91f3c7fee8561bd42f87fa82894b17cac51daeab94a298a7cc3bc5c0158c4fdead62879e89ea760beb3222e5bf31489b68a3483b47adb499
+DIST sphinx-autoapi-3.1.1.gh.tar.gz 67903 BLAKE2B aec809e53b2c1080a29c49f5d9916df2e9def0c2072d99dde7ee3250a9cc7a9fc2d1e3e76ad954cfc417205c9b8994dcb7d0533f5994eb2a584d8ffa3ee3260e SHA512 c5a3db4f6e3969af8f8f2933822e577d3469c649f6976327e55c449cd6992274ee896a7ad01d5a3bfab378819bd4fe319b9f08e989214c00b4844c03c56ed2c8
EBUILD sphinx-autoapi-3.0.0.ebuild 1172 BLAKE2B cb62d7d3c9d33f101731ece4f539f9a842725db53b8259681fdf318b71874fe4995c5532e4a341bd42ba0399ecb3f7562c1a62832725c222cb486290d6174b64 SHA512 b392a5c3651f0e2ece1e3fb8c50f6a3a765b606ef44d187ee8358852d5ace5a495b5be983dfee2a9bd5083818b7c0ef3dedd66cd4d1202361f52fe524c057bdc
EBUILD sphinx-autoapi-3.1.0.ebuild 1204 BLAKE2B a579b2d50c84d93a517f4ce46d56f0989d5332e03adefcacae1d66d9c17ef641c9e8429d926529550e35bc5083defc8871eb3840295bb7cbb5b0a2e5b52f6993 SHA512 87782e5a48582dacdba1a6b1aff2559201db0f4943a5cbf1402f91c4889003fee713f622182a65bf088d14ccc8d3b02d25a49c8cd30b1b893dd30aeffc715a9b
+EBUILD sphinx-autoapi-3.1.1.ebuild 1204 BLAKE2B a579b2d50c84d93a517f4ce46d56f0989d5332e03adefcacae1d66d9c17ef641c9e8429d926529550e35bc5083defc8871eb3840295bb7cbb5b0a2e5b52f6993 SHA512 87782e5a48582dacdba1a6b1aff2559201db0f4943a5cbf1402f91c4889003fee713f622182a65bf088d14ccc8d3b02d25a49c8cd30b1b893dd30aeffc715a9b
MISC metadata.xml 769 BLAKE2B 6f85e487a2d2def289bb54a6addc2338bb8af85b323ec1c95851945f9c407ec22bfadd8079ac8b6e00cfbc85caa0e2b09d82329f1f87a365fc44b69c7bcd9a20 SHA512 68f02a5f98234c2a5cb15aa04ce90077b154a7e3a7a69dc0a1d0a6b5c7b42c60624878a7e2fff1576c8b586fc15e7ef042942274d4e8473835bb3d8bfdbd8393
diff --git a/dev-python/sphinx-autoapi/sphinx-autoapi-3.1.1.ebuild b/dev-python/sphinx-autoapi/sphinx-autoapi-3.1.1.ebuild
new file mode 100644
index 000000000000..9182b8aa4e2c
--- /dev/null
+++ b/dev-python/sphinx-autoapi/sphinx-autoapi-3.1.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A new approach to API documentation in Sphinx"
+HOMEPAGE="
+ https://sphinx-autoapi.readthedocs.io/
+ https://github.com/readthedocs/sphinx-autoapi/
+ https://pypi.org/project/sphinx-autoapi/
+"
+# sdist is missing docs, as of 2.1.0
+SRC_URI="
+ https://github.com/readthedocs/sphinx-autoapi/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/astroid-3.0.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-6.1.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND+="
+ test? ( dev-python/beautifulsoup4[${PYTHON_USEDEP}] )
+"
+
+DOCS=( README.rst CHANGELOG.rst )
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/python/test_pyintegration.py::TestPEP695::test_integration
+ tests/python/test_pyintegration.py::TestPipeUnionModule::test_integration
+ "tests/test_integration.py::TestExtensionErrors::test_extension_setup_errors[dotnetexample"
+ )
+
+ distutils-r1_python_test
+}