summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-autoapi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-11 14:17:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-11 14:17:10 +0100
commit5adfd733728a4f14df5665f4c2a604a7356e5f19 (patch)
treef2938c4a08576b45508b02481edfec55eac3ac8b /dev-python/sphinx-autoapi
parentfbba40085f5d1591a67b49f5aa48b4071b7560f1 (diff)
gentoo auto-resync : 11:06:2023 - 14:17:09
Diffstat (limited to 'dev-python/sphinx-autoapi')
-rw-r--r--dev-python/sphinx-autoapi/Manifest2
-rw-r--r--dev-python/sphinx-autoapi/sphinx-autoapi-2.1.1.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/sphinx-autoapi/Manifest b/dev-python/sphinx-autoapi/Manifest
index 1bc2f7b0aee6..8d6c4d6c6139 100644
--- a/dev-python/sphinx-autoapi/Manifest
+++ b/dev-python/sphinx-autoapi/Manifest
@@ -1,3 +1,5 @@
DIST sphinx-autoapi-2.1.0.gh.tar.gz 84842 BLAKE2B 0020640833039c5c15babeb2ed37bffa9a836209e51bb5d4873ccd34527f6b652516ceed95d2e823a9394e6154ea36311a78fcf0645723c3060a6eb7f31b0668 SHA512 4228c0d7c91a89933101d1c02689f1e25c453ead66814f8653f1e20b6330a20913b8d98573b3afb5459be972b73535cbe81fd267e721bedfb78a2de4673fa9e2
+DIST sphinx-autoapi-2.1.1.gh.tar.gz 86463 BLAKE2B 412a2c35bfddeb951de66648f39416bfed98ef357e540bf7fd85c4b6962cc97145519b98f87ea207580cb69c1b03260eedfb4872a389cd2dfe56bfe9c9868e46 SHA512 ec562b89f09b7b42cee283e471ab464e07f071f694fdd906984befab5669bcbe7c5d26e7aa2a81d9c64210680408998cbeade6cd8f6a988c3604e3846160ab2d
EBUILD sphinx-autoapi-2.1.0.ebuild 1561 BLAKE2B 0434dfc0e43eae17b8410018675b7fcd34276189c4fcb9e2b72b807b2be24f54cf66ed9aced94be9c0711702a3412453116e50d6417b573a506dead7f5baa652 SHA512 835c00b89dd39f0fbe41488e7ba46f9df6f4c5aadf5d94db548c5606bc7119543dcb75f673d18e0e2d139f73868e8c8a7a9390add0315f8e0ddd40295fd923ce
+EBUILD sphinx-autoapi-2.1.1.ebuild 1154 BLAKE2B fb0af70c8cda7b4f4177dd6780723b2b40b7888503acb34e7328823af38677880f2582311af109f337ab88bdd00f1d5d9815d88163ab17b65eb7e667c04b3017 SHA512 c23ad642f53d4aa224db065c7ae0f7c4a3c0b91b76268f10958f1f6369ad57881e51f16e4b1c588ea3d34efb31ba0932344de8678b5c7a8a71c7b254c6e875b5
MISC metadata.xml 769 BLAKE2B 6f85e487a2d2def289bb54a6addc2338bb8af85b323ec1c95851945f9c407ec22bfadd8079ac8b6e00cfbc85caa0e2b09d82329f1f87a365fc44b69c7bcd9a20 SHA512 68f02a5f98234c2a5cb15aa04ce90077b154a7e3a7a69dc0a1d0a6b5c7b42c60624878a7e2fff1576c8b586fc15e7ef042942274d4e8473835bb3d8bfdbd8393
diff --git a/dev-python/sphinx-autoapi/sphinx-autoapi-2.1.1.ebuild b/dev-python/sphinx-autoapi/sphinx-autoapi-2.1.1.ebuild
new file mode 100644
index 000000000000..a462dcc36bc9
--- /dev/null
+++ b/dev-python/sphinx-autoapi/sphinx-autoapi-2.1.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A new approach to API documentation in Sphinx"
+HOMEPAGE="
+ https://sphinx-autoapi.readthedocs.io/
+ https://github.com/readthedocs/sphinx-autoapi/
+ https://pypi.org/project/sphinx-autoapi/
+"
+# sdist is missing docs, as of 2.1.0
+SRC_URI="
+ https://github.com/readthedocs/sphinx-autoapi/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/anyascii[${PYTHON_USEDEP}]
+ dev-python/astroid[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-6.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND+="
+ test? ( dev-python/beautifulsoup4[${PYTHON_USEDEP}] )
+"
+
+DOCS=( README.rst CHANGELOG.rst )
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/python/test_pyintegration.py::TestPipeUnionModule::test_integration
+ "tests/test_integration.py::TestExtensionErrors::test_extension_setup_errors[dotnetexample"
+ )
+
+ distutils-r1_python_test
+}