summaryrefslogtreecommitdiff
path: root/dev-python/spake2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-26 03:07:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-26 03:07:48 +0100
commit5923f7107d7596f9ecb6a86b451105462668601c (patch)
tree57ebb2966a1787500108baf49e27b002aaaed0ce /dev-python/spake2
parent633591ecdf876d163972f90145c0ca61e6c496fa (diff)
gentoo auto-resync : 26:05:2023 - 03:07:47
Diffstat (limited to 'dev-python/spake2')
-rw-r--r--dev-python/spake2/Manifest3
-rw-r--r--dev-python/spake2/metadata.xml13
-rw-r--r--dev-python/spake2/spake2-0.8.ebuild24
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/spake2/Manifest b/dev-python/spake2/Manifest
new file mode 100644
index 000000000000..713e65a50125
--- /dev/null
+++ b/dev-python/spake2/Manifest
@@ -0,0 +1,3 @@
+DIST spake2-0.8.gh.tar.gz 62425 BLAKE2B 64215362af26fff0785fdabf4282f7111a4cc917750827075b616f009cb1fa6373fc2325382c26b43c051aa5b94e414ca2a5223d9ab666289eb2d04723b15cb5 SHA512 908c377c831f4a11551973ca917b113d51a66c533d35fd19b2692fdb7e575ed2a5045d9b632bc55c37b68ad092f01dff5da191e9dfbfb5599b72844788438d68
+EBUILD spake2-0.8.ebuild 635 BLAKE2B 51a609794569458dffe2f3c288d26a19bb4efc12d5f9b8b91509be35495ac334ff03acad560a1424f180dd5e0da943b22120a1ff7a452934a97a44a53ecf9179 SHA512 c38a16bb40a5cd7dca004c2f4cac7cb26c5f62e8ca63444a3701cdae3a1c27aac49d6dcb4ad695b62ea101c5841a6dcffa472f690f7b7516e84e784eda124e65
+MISC metadata.xml 401 BLAKE2B a80b9d771ec1251af6e16f012257a7d1150644cdba64052ff5b70d282c6f27fa57685f675409a3edf30b2c2bc24c85f74b3dd8460999f8497a72e93653183abc SHA512 ecfbcd80d35348bbb1a5469bcca1b06a86ca6fe736d443707e00859400318e5c9bb399e5acf2faaf2771301518741ec93124277f6bf1834454b4406392cf0ea4
diff --git a/dev-python/spake2/metadata.xml b/dev-python/spake2/metadata.xml
new file mode 100644
index 000000000000..2041ad286cee
--- /dev/null
+++ b/dev-python/spake2/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">spake2</remote-id>
+ <remote-id type="github">warner/python-spake2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/spake2/spake2-0.8.ebuild b/dev-python/spake2/spake2-0.8.ebuild
new file mode 100644
index 000000000000..8fa00484e842
--- /dev/null
+++ b/dev-python/spake2/spake2-0.8.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="python implementation of SPAKE2 password-authenticated key exchange algorithm"
+HOMEPAGE="https://pypi.org/project/spake2/"
+SRC_URI="https://github.com/warner/python-${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}/python-${P}"
+
+RDEPEND="
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/hkdf[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest