summaryrefslogtreecommitdiff
path: root/dev-python/spake2/spake2-0.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-26 03:07:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-26 03:07:48 +0100
commit5923f7107d7596f9ecb6a86b451105462668601c (patch)
tree57ebb2966a1787500108baf49e27b002aaaed0ce /dev-python/spake2/spake2-0.8.ebuild
parent633591ecdf876d163972f90145c0ca61e6c496fa (diff)
gentoo auto-resync : 26:05:2023 - 03:07:47
Diffstat (limited to 'dev-python/spake2/spake2-0.8.ebuild')
-rw-r--r--dev-python/spake2/spake2-0.8.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/spake2/spake2-0.8.ebuild b/dev-python/spake2/spake2-0.8.ebuild
new file mode 100644
index 000000000000..8fa00484e842
--- /dev/null
+++ b/dev-python/spake2/spake2-0.8.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="python implementation of SPAKE2 password-authenticated key exchange algorithm"
+HOMEPAGE="https://pypi.org/project/spake2/"
+SRC_URI="https://github.com/warner/python-${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}/python-${P}"
+
+RDEPEND="
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/hkdf[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest