summaryrefslogtreecommitdiff
path: root/dev-python/sortedcontainers
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/sortedcontainers
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/sortedcontainers')
-rw-r--r--dev-python/sortedcontainers/Manifest3
-rw-r--r--dev-python/sortedcontainers/sortedcontainers-2.4.0-r1.ebuild32
-rw-r--r--dev-python/sortedcontainers/sortedcontainers-2.4.0.ebuild4
3 files changed, 36 insertions, 3 deletions
diff --git a/dev-python/sortedcontainers/Manifest b/dev-python/sortedcontainers/Manifest
index 3be5266ad9c2..53f157c7a882 100644
--- a/dev-python/sortedcontainers/Manifest
+++ b/dev-python/sortedcontainers/Manifest
@@ -1,3 +1,4 @@
DIST python-sortedcontainers-2.4.0.gh.tar.gz 9229380 BLAKE2B ca9348ab7d467b2a81126217451262bb0547901b953edc3bba7c87c67b415eef5c3d454a08d227ebc8b213c1cc7db6262e864511fe67beefe865014ae5fc5977 SHA512 f80185c6f95a85cc78f88f6f6cf389eb48be22cf94d5fcd84f3592873f17de37ec7f44c1627b7f02956ac4b4f74ca4febefc47d3c6232f70ee05dbb2449ad770
-EBUILD sortedcontainers-2.4.0.ebuild 802 BLAKE2B 1b3ad2046bdefad599498d02ac27a17e738ac1d1bea4d995e36ac4a5ad075ff2469a52bb537e64311009923dd1bb453bb45d6100973be210b73f150fa2466a98 SHA512 d2e086e2b8f4fa0c7962021dcec78e13da1613ecd6312120434d62129c52c61d785f71dd1e3034956f1a1d6758b65c8e672e25b30b23e7d7e3adf175536c189d
+EBUILD sortedcontainers-2.4.0-r1.ebuild 838 BLAKE2B 22549b4c234d1ed872c781ca0d1f7a8d2e9aa0b5283e7805f8dcef8956176083bd029d9ae5d4c7f387e34b64e54424f5264a1011f95694d2b3e68dba12421c5e SHA512 a4651479a9bc1323112515fde4eb26c54a3595f084de29f6c6d2e7ae92af9a6b0bca94e683c4b9b12143fc95f0bd2fc64e1b20ead0c4b8f1f134de99503012ac
+EBUILD sortedcontainers-2.4.0.ebuild 809 BLAKE2B e69298d6b2208ee6cc133c5548a5f1f653b39917faec4d5a8dd2012a4b7cabd9be29e45f1cf1db4ba0d049d43f33b48bb0e2eec60a540bc65c39276afa566b92 SHA512 8a27fd894f0f6d24b229994fd06fe8e3e14e815d664d5948f81cb1c4efc87c120b4ecea626675b900465ba7cd3e63bd22784855e1b26107871a2ebc0b6fb4466
MISC metadata.xml 418 BLAKE2B 570f73c8991668cf196d77b2a5ebec502a6ccc42322db114e2b82c9b798641c178481854bb8caee377b48888714509cc71edf335ea046748cd575ba293cc6588 SHA512 e1f7beeaea74e5f18b02ae8dc0a6ce776190c281317a963c151848078333e3fb8834b2633ffb8e96fe1fd455e3ad556721b1d3291228457ca059ca9c13cb99af
diff --git a/dev-python/sortedcontainers/sortedcontainers-2.4.0-r1.ebuild b/dev-python/sortedcontainers/sortedcontainers-2.4.0-r1.ebuild
new file mode 100644
index 000000000000..0ee6fc703b66
--- /dev/null
+++ b/dev-python/sortedcontainers/sortedcontainers-2.4.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Python library to sort collections and containers"
+HOMEPAGE="
+ https://www.grantjenks.com/docs/sortedcontainers/
+ https://github.com/grantjenks/python-sortedcontainers/
+ https://pypi.org/project/sortedcontainers/
+"
+SRC_URI="
+ https://github.com/grantjenks/python-sortedcontainers/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest --ignore docs/conf.py
+}
diff --git a/dev-python/sortedcontainers/sortedcontainers-2.4.0.ebuild b/dev-python/sortedcontainers/sortedcontainers-2.4.0.ebuild
index 76cdbde4ac77..17aab8883a00 100644
--- a/dev-python/sortedcontainers/sortedcontainers-2.4.0.ebuild
+++ b/dev-python/sortedcontainers/sortedcontainers-2.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,7 +18,7 @@ S=${WORKDIR}/${MY_P}
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
distutils_enable_tests pytest