summaryrefslogtreecommitdiff
path: root/dev-python/sniffio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-python/sniffio
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-python/sniffio')
-rw-r--r--dev-python/sniffio/Manifest2
-rw-r--r--dev-python/sniffio/sniffio-1.2.0.ebuild14
2 files changed, 6 insertions, 10 deletions
diff --git a/dev-python/sniffio/Manifest b/dev-python/sniffio/Manifest
index ca736140b6e6..e72447dcf37a 100644
--- a/dev-python/sniffio/Manifest
+++ b/dev-python/sniffio/Manifest
@@ -1,3 +1,3 @@
DIST sniffio-1.2.0.gh.tar.gz 17335 BLAKE2B 0d67baa18702ac38932680bdc741c87ee0a31342cc752c1463a7f90720ea0ebf6d62ef682a042c58e8fe96456e1461638e0f02c6f60da5f5e0d07464be27a4a3 SHA512 8e1dd2bb6fc22ee5824adfffe688ff0621b8c1ef5daea594dedce13d5e04a498e05816bb32e9bbed206a653a330ff710df57c888ddcff00a6254eafddc538273
-EBUILD sniffio-1.2.0.ebuild 704 BLAKE2B 67d6244fe9188fabf3b85f2fe23791cd0dcc40f2a5cae29e00d6a50d7267d65ec5bfe9616ed6bea79e4454da842f8ae54fe182a53c87fc79ad236103ab284dac SHA512 4e2f6aff45ef8530048f72a9c4053c527cb10df24d6f1b0729cb56019ac24469ba74fbe451eb4faf3a924b4d241207fbeb97475dff62db05207830bb09356365
+EBUILD sniffio-1.2.0.ebuild 651 BLAKE2B 62eacfd83cdba87227daa3ce6b10520437054fbfa408fdf36ac42198a00cdd5bc8afbb0cf5005b7ac7e84f22539425d1cde883ef051921c51285601adfb733e0 SHA512 8cce90d07851ee07348cfccb3f806d20f8272a90c9cc7c8a06c39595c7a01841e4bba00f249b02cda0c4834ab94b19193660d9fb5f4e19031ef6bc3ac420bcf9
MISC metadata.xml 394 BLAKE2B 46df2a6c1c3259a1ba932cb74918ee0f7651e942cdb2eaa76d063269417079459745fa80416cab8088b8f41699b3b509a4586ab828692698a6a04588ece79bbc SHA512 a1aebdbc40dab66e913aaa7dd848066197d8d53a3e5c4890953cf6e5ffd1df5f5acae5ed022b10fc9c6e9a51becd05ff31ac19d0013ad7786b6d038705696b73
diff --git a/dev-python/sniffio/sniffio-1.2.0.ebuild b/dev-python/sniffio/sniffio-1.2.0.ebuild
index f6f3ddbd3664..13064b3ad091 100644
--- a/dev-python/sniffio/sniffio-1.2.0.ebuild
+++ b/dev-python/sniffio/sniffio-1.2.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Sniff out which async library your code is running under"
@@ -20,11 +20,7 @@ KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86"
distutils_enable_tests pytest
-python_test() {
- local deselect=(
- # curio is not packaged
- sniffio/_tests/test_sniffio.py::test_curio
- )
-
- epytest ${deselect[@]/#/--deselect }
-}
+EPYTEST_DESELECT=(
+ # curio is not packaged
+ sniffio/_tests/test_sniffio.py::test_curio
+)