summaryrefslogtreecommitdiff
path: root/dev-python/sniffio/sniffio-1.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-26 05:40:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-26 05:40:24 +0000
commit8786557f50665cfd3a22ad42ec92209c4d6eae66 (patch)
tree7cf41a52a48ef4334d8fd43daaff3c2212fa937f /dev-python/sniffio/sniffio-1.3.1.ebuild
parent4846d367ad566eb7f93a432cae0d261f28f65255 (diff)
gentoo auto-resync : 26:02:2024 - 05:40:24
Diffstat (limited to 'dev-python/sniffio/sniffio-1.3.1.ebuild')
-rw-r--r--dev-python/sniffio/sniffio-1.3.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/sniffio/sniffio-1.3.1.ebuild b/dev-python/sniffio/sniffio-1.3.1.ebuild
new file mode 100644
index 000000000000..57640b5c7fc1
--- /dev/null
+++ b/dev-python/sniffio/sniffio-1.3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sniff out which async library your code is running under"
+HOMEPAGE="
+ https://github.com/python-trio/sniffio/
+ https://pypi.org/project/sniffio/
+"
+SRC_URI="
+ https://github.com/python-trio/sniffio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # curio is not packaged
+ sniffio/_tests/test_sniffio.py::test_curio
+)