summaryrefslogtreecommitdiff
path: root/dev-python/snakeoil/snakeoil-0.7.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /dev-python/snakeoil/snakeoil-0.7.5.ebuild
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'dev-python/snakeoil/snakeoil-0.7.5.ebuild')
-rw-r--r--dev-python/snakeoil/snakeoil-0.7.5.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/snakeoil/snakeoil-0.7.5.ebuild b/dev-python/snakeoil/snakeoil-0.7.5.ebuild
deleted file mode 100644
index 16d993d1aa5c..000000000000
--- a/dev-python/snakeoil/snakeoil-0.7.5.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_6,3_7} )
-PYTHON_REQ_USE="threads(+)"
-inherit distutils-r1
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
- inherit git-r3
-else
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86"
- SRC_URI="https://github.com/pkgcore/snakeoil/releases/download/v${PV}/${P}.tar.gz"
-fi
-
-DESCRIPTION="misc common functionality and useful optimizations"
-HOMEPAGE="https://github.com/pkgcore/snakeoil"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/mock[${PYTHON_USEDEP}] )"
-[[ ${PV} == 9999 ]] && DEPEND+=" $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]' 'python3*')"
-
-python_configure_all() {
- # disable snakeoil 2to3 caching
- unset PY2TO3_CACHEDIR
-}
-
-python_test() {
- esetup.py test
-}