summaryrefslogtreecommitdiff
path: root/dev-python/smmap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/smmap
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/smmap')
-rw-r--r--dev-python/smmap/Manifest4
-rw-r--r--dev-python/smmap/smmap-0.9.0.ebuild32
-rw-r--r--dev-python/smmap/smmap-3.0.1.ebuild20
3 files changed, 22 insertions, 34 deletions
diff --git a/dev-python/smmap/Manifest b/dev-python/smmap/Manifest
index c38b2da760aa..1a85d87f1862 100644
--- a/dev-python/smmap/Manifest
+++ b/dev-python/smmap/Manifest
@@ -1,3 +1,3 @@
-DIST smmap-0.9.0.tar.gz 22082 BLAKE2B a0c7e5957a4ea829a3f7855ac5d05660ac2bc6ed8e58a50b805a4c07899ce5022d5bbc0329604dd2296dace3e6e6165cb108be8014c4c834629f830af14a4562 SHA512 704e1c67b1f3e1303578cc26d4af8296a11b5f5013e8e8d933d3096e588911b801ddfb162d0e35a49c00256032824386d77e4f38d58704cd57baf21586b40e03
-EBUILD smmap-0.9.0.ebuild 685 BLAKE2B 95c1df4d7f2ec6f61c5276b9044f638b980a22095ee13e584f1a5cd5543b1584a2e4feac04a09144a1e445772d4248df657abb893175583a6af2eb49274be5f8 SHA512 33f270b3ed764e36cba31b04f395b47e70116b1872f54b1f33efadc15a86982098ed90f5e21dd0945eab17eff0b879c6ff8a4d9b3f5545b21ba8d1cb8693a3d7
+DIST smmap-3.0.1.tar.gz 23659 BLAKE2B 19a9425d039141acc00ddc939dab97390d6f619b2d9049ee9c8e483718da1dc06fcd937c6736ecf91a4d55af2b5ff7612de93690334fbfa9bc3904a597e517bd SHA512 36594896212d218c5bc9e27ae16f692643d2236ff13a55461a35d0d688fcf40f6082caa003f178d7bd8b999d4571de269d708f299413dbef46b58ae2074bfc9a
+EBUILD smmap-3.0.1.ebuild 468 BLAKE2B 9e7fcb65a2635cb8eed99a8523eb474072d7e94ac5fc20343cc0e48fb4c17283589a5e5cb08f980ddcb3145d08f2e472d1729e579b7117e3553ed4176a75d97a SHA512 e5157e0aedf057cb6bca0ae336b70d7d637da63ac81b44c9679f14cbd4ef8e113b84031ecf001bf8626d61e8f4dfbff88ced5ca2da9ed988586cfc1c9f0cba8d
MISC metadata.xml 371 BLAKE2B 3e42cbd127ee25fe4e316797aed0977eab484119096a606b517fa8d57d2ecbeebd4c4b51570dbda7771d1b9bf6bca368b5fc97379f08e2c1ea51121628d109d1 SHA512 9f6f41b53acf58ff0b7ed064469b5b66820f6c173b657ce59d9501d78f87ff2667b84bd0be275f6aa2d06752d875c5aba83105f5414b2b50a86fce9008685f3c
diff --git a/dev-python/smmap/smmap-0.9.0.ebuild b/dev-python/smmap/smmap-0.9.0.ebuild
deleted file mode 100644
index 6e5b48410c1c..000000000000
--- a/dev-python/smmap/smmap-0.9.0.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="A pure git implementation of a sliding window memory map manager"
-HOMEPAGE="
- https://pypi.org/project/smmap/
- https://github.com/Byron/smmap"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-KEYWORDS="amd64 ~arm64 x86"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/nosexcover[${PYTHON_USEDEP}]
- )"
-RDEPEND=""
-
-python_test() {
- nosetests || die "tests failed under ${EPYTHON}"
-}
diff --git a/dev-python/smmap/smmap-3.0.1.ebuild b/dev-python/smmap/smmap-3.0.1.ebuild
new file mode 100644
index 000000000000..73277c500b93
--- /dev/null
+++ b/dev-python/smmap/smmap-3.0.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure Python implementation of a sliding window memory map manager"
+HOMEPAGE="
+ https://pypi.org/project/smmap/
+ https://github.com/Byron/smmap"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm64 ~x86"
+SLOT="0"
+
+distutils_enable_tests unittest