summaryrefslogtreecommitdiff
path: root/dev-python/smmap/smmap-6.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-17 17:03:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-17 17:03:45 +0100
commitc9e9e39938097bf29063c271195ad0d7d7bd02a9 (patch)
treef2f4ab36d22272fec3a1d1313d8f700b1f0f6744 /dev-python/smmap/smmap-6.0.0.ebuild
parent0968caae52d6eae7513e2ce4e0900a2e009780ee (diff)
gentoo auto-resync : 17:09:2023 - 17:03:44
Diffstat (limited to 'dev-python/smmap/smmap-6.0.0.ebuild')
-rw-r--r--dev-python/smmap/smmap-6.0.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/smmap/smmap-6.0.0.ebuild b/dev-python/smmap/smmap-6.0.0.ebuild
new file mode 100644
index 000000000000..d90c313bdb60
--- /dev/null
+++ b/dev-python/smmap/smmap-6.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pure Python implementation of a sliding window memory map manager"
+HOMEPAGE="
+ https://pypi.org/project/smmap/
+ https://github.com/gitpython-developers/smmap/
+"
+
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+distutils_enable_tests unittest