summaryrefslogtreecommitdiff
path: root/dev-python/smmap/smmap-5.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/smmap/smmap-5.0.0.ebuild
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/smmap/smmap-5.0.0.ebuild')
-rw-r--r--dev-python/smmap/smmap-5.0.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/smmap/smmap-5.0.0.ebuild b/dev-python/smmap/smmap-5.0.0.ebuild
new file mode 100644
index 000000000000..ca18803bed80
--- /dev/null
+++ b/dev-python/smmap/smmap-5.0.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A pure Python implementation of a sliding window memory map manager"
+HOMEPAGE="
+ https://pypi.org/project/smmap/
+ https://github.com/gitpython-developers/smmap/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+SLOT="0"
+
+distutils_enable_tests unittest