summaryrefslogtreecommitdiff
path: root/dev-python/smartypants/smartypants-2.0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-20 15:52:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-20 15:52:41 +0100
commitb3830a745865c7d85daf3317603ad23dac6434da (patch)
tree8bacb840498f00754dc51ec2ab76bb175f52fc58 /dev-python/smartypants/smartypants-2.0.1-r1.ebuild
parent547caa904733bc2a3ac112415990a114ecbe8824 (diff)
gentoo auto-resync : 20:10:2023 - 15:52:41
Diffstat (limited to 'dev-python/smartypants/smartypants-2.0.1-r1.ebuild')
-rw-r--r--dev-python/smartypants/smartypants-2.0.1-r1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-python/smartypants/smartypants-2.0.1-r1.ebuild b/dev-python/smartypants/smartypants-2.0.1-r1.ebuild
index c05ab9b7a76b..e1ab8ba2d497 100644
--- a/dev-python/smartypants/smartypants-2.0.1-r1.ebuild
+++ b/dev-python/smartypants/smartypants-2.0.1-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -16,7 +16,7 @@ HOMEPAGE="
"
SRC_URI="
https://github.com/leohemsted/smartypants.py/archive/v${PV}.tar.gz
- -> ${P}.tar.gz
+ -> ${P}.gh.tar.gz
"
S=${WORKDIR}/${MY_P}
@@ -28,6 +28,11 @@ distutils_enable_sphinx docs
distutils_enable_tests unittest
src_prepare() {
+ local PATCHES=(
+ # https://github.com/leohemsted/smartypants.py/pull/21
+ "${FILESDIR}/${P}-py312.patch"
+ )
+
# relevant only to upstream packaging, requires docutils
rm tests/test_setup.py || die
distutils-r1_src_prepare