summaryrefslogtreecommitdiff
path: root/dev-python/slixmpp/slixmpp-1.8.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-13 12:48:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-13 12:48:53 +0000
commit7c1ac01728d0156998ee45be74f80b378d96c31d (patch)
tree6634bea5058fa5133bb0227fd6f1da9aea4ca8f7 /dev-python/slixmpp/slixmpp-1.8.3.ebuild
parentb2d06fcf55b2f88efa183831072c7bca3f8e418b (diff)
gentoo auto-resync : 13:11:2022 - 12:48:53
Diffstat (limited to 'dev-python/slixmpp/slixmpp-1.8.3.ebuild')
-rw-r--r--dev-python/slixmpp/slixmpp-1.8.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/slixmpp/slixmpp-1.8.3.ebuild b/dev-python/slixmpp/slixmpp-1.8.3.ebuild
new file mode 100644
index 000000000000..a4b3ead83d1d
--- /dev/null
+++ b/dev-python/slixmpp/slixmpp-1.8.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3 library for XMPP"
+HOMEPAGE="https://lab.louiz.org/poezio/slixmpp"
+LICENSE="MIT"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://lab.louiz.org/poezio/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~riscv"
+fi
+
+DEPEND="
+ net-dns/libidn:=
+"
+RDEPEND="
+ dev-python/aiodns[${PYTHON_USEDEP}]
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ ${DEPEND}
+"
+
+distutils_enable_tests unittest