summaryrefslogtreecommitdiff
path: root/dev-python/slimit/slimit-0.8.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/slimit/slimit-0.8.1-r1.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/slimit/slimit-0.8.1-r1.ebuild')
-rw-r--r--dev-python/slimit/slimit-0.8.1-r1.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/dev-python/slimit/slimit-0.8.1-r1.ebuild b/dev-python/slimit/slimit-0.8.1-r1.ebuild
index c65e63cdd426..b5af60f39209 100644
--- a/dev-python/slimit/slimit-0.8.1-r1.ebuild
+++ b/dev-python/slimit/slimit-0.8.1-r1.ebuild
@@ -3,7 +3,9 @@
EAPI=6
+DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( pypy3 python3_6 )
+
inherit distutils-r1
DESCRIPTION="A JavaScript minifier written in Python"
@@ -13,19 +15,13 @@ SRC_URI="https://github.com/rspivak/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-RDEPEND="dev-python/ply:=[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- )"
+RDEPEND="dev-python/ply:=[${PYTHON_USEDEP}]"
PATCHES=( "${FILESDIR}/${P}-fix-python3.patch" )
+distutils_enable_tests pytest
+
python_compile() {
distutils-r1_python_compile
@@ -38,5 +34,5 @@ python_compile() {
}
python_test() {
- esetup.py pytest --addopts "${BUILD_DIR}" || die "Testing failed with ${EPYTHON}"
+ pytest -vv "${BUILD_DIR}" || die "Tests failed with ${EPYTHON}"
}