summaryrefslogtreecommitdiff
path: root/dev-python/six
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/six
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/Manifest7
-rw-r--r--dev-python/six/files/1.10.0-no-setuptools.patch22
-rw-r--r--dev-python/six/files/1.9.0-mapping.patch12
-rw-r--r--dev-python/six/metadata.xml12
-rw-r--r--dev-python/six/six-1.10.0.ebuild65
-rw-r--r--dev-python/six/six-1.11.0.ebuild39
6 files changed, 157 insertions, 0 deletions
diff --git a/dev-python/six/Manifest b/dev-python/six/Manifest
new file mode 100644
index 000000000000..02b845643d7c
--- /dev/null
+++ b/dev-python/six/Manifest
@@ -0,0 +1,7 @@
+AUX 1.10.0-no-setuptools.patch 545 BLAKE2B e884088c94e36283ce3e9a8df716cf25b040d3c724e0ab7499c2f0c6cff5680ef04461b2a8f56e348e50c88a8f29bda053161f02e1bc5dcff36176179b0722b5 SHA512 f1d5c25815fb9e2ecfccaecef52383d468163feff0391214650f109560282ce2eff51513a60824a15ccc3a5af09fe0411b387314978af9a1f51fccc387521ffe
+AUX 1.9.0-mapping.patch 561 BLAKE2B 281a893fa6d0d589eb768c595e8931e4d743be9bc7eb288d87628f6a38c14a220f965430c0a480aecf0652c09155359aff9dff11449e2de3c55d7ef00f2527d3 SHA512 92d5bb1643264a04d5faf36bed16379e8844648a31739921bd97e2dd88e34a9b302c37a12a15a64aceb3d26c53f7cdbcbde2ce8d289a7a43f692af47bf05f58c
+DIST six-1.10.0.tar.gz 29630 BLAKE2B 1f380dbc7a9e746b4a7909de54a58a008a73d7b6c582611b2481475d5d9971c936b1742ea0821c65150694914af72f43155caa54616268735a4bd2447d5b4ba4 SHA512 9a53b7bc8f7e8b358c930eaecf91cc5639176a699830153f586780c3e6d637f1bd31349a69c383574f99da19cb3a36524e7733a318f3572b27aefb69c6409c2e
+DIST six-1.11.0.tar.gz 29860 BLAKE2B de4886ad9af7aa906f9eac213544c99323d74c1988d9abff96ce6fc3eea4464e577511f7c52328cbd9e6989db2128fa8d1ee57f9ce7bfc36b83ff655691b46c9 SHA512 33f246a2e987141e17e5edad9d3537cf3aba0cbdd0bc2a907ea52ce0d674b1474f29c3dd5cc26605fd960396054b189ca5f501708333cad234c223131483fe24
+EBUILD six-1.10.0.ebuild 1817 BLAKE2B cf11b48d603e01500cb2147756d7197bd5fad06de42ed91c0ecbb967f36f22fcf0e9d9d33a552dce6e0cd05cf0634d266c41aebd4cd4bfec6acc9960401d0729 SHA512 4a33dd217477d6c2a5488970cad9481c929fa4996d386d203caf3a3abb7e545a90f9df13e068a96d9040cc3d65c4305eff5f52bb51cc4743bbc1791500968a73
+EBUILD six-1.11.0.ebuild 1079 BLAKE2B 2bc9b79a728a733a5e51cc5ca118b5c9960774b18fdea64c9ee8d172aa0a0d48965a30c193050d403dd4b3d0d38da9d4d883a1e9a1b45430b8a733742ae4f415 SHA512 33562079526f6eaa36a8e129d876d4700256ee37dc076567307827abd6de62b231312827ad8e6d67751ed4ead33676dd85abb3d774627ca2b1577b357ccbc48e
+MISC metadata.xml 371 BLAKE2B 475b717d4c4bced0454ee0244b5d30f178098ff45b2fc7d168b41f446c4e8f3f2dc022ccadb953d6f4e905f95e38769657d42fb4d80157c816d6e7b5eddb33c2 SHA512 8171125815ab60f7c9a2756367ee6532fd862c5f411ff828b6555e4e21e6d43672f2c764f92134f6625abb161380bdbb739af259ba88c974cf3583f35af76a91
diff --git a/dev-python/six/files/1.10.0-no-setuptools.patch b/dev-python/six/files/1.10.0-no-setuptools.patch
new file mode 100644
index 000000000000..d4309181902a
--- /dev/null
+++ b/dev-python/six/files/1.10.0-no-setuptools.patch
@@ -0,0 +1,22 @@
+Force distutils to avoid depending on setuptools
+
+distutils and setuptools have differing behavior in regard to egg-info
+directories versus files, so we need to ensure that no automagic behavior
+occurs here.
+
+We cannot hard-depend on setuptools due to a circular dependency.
+
+diff --git a/setup.py b/setup.py
+--- a/setup.py
++++ b/setup.py
+@@ -1,9 +1,6 @@
+ from __future__ import with_statement
+
+-try:
+- from setuptools import setup
+-except ImportError:
+- from distutils.core import setup
++from distutils.core import setup
+
+ import six
+
diff --git a/dev-python/six/files/1.9.0-mapping.patch b/dev-python/six/files/1.9.0-mapping.patch
new file mode 100644
index 000000000000..4423eacbbba3
--- /dev/null
+++ b/dev-python/six/files/1.9.0-mapping.patch
@@ -0,0 +1,12 @@
+Patch prevents downloading non essential .inv files during the doc build
+diff -ur six-1.5.2.orig/documentation/conf.py six-1.5.2/documentation/conf.py
+--- a/documentation/conf.py 2013-09-15 21:52:34.000000000 +0800
++++ b/documentation/conf.py 2014-01-07 18:19:24.958916446 +0800
+@@ -211,7 +211,3 @@
+ [u"Benjamin Peterson"], 1)
+ ]
+
+-# -- Intersphinx ---------------------------------------------------------------
+-
+-intersphinx_mapping = {"py2" : ("https://docs.python.org/2/", None),
+- "py3" : ("https://docs.python.org/3/", None)}
diff --git a/dev-python/six/metadata.xml b/dev-python/six/metadata.xml
new file mode 100644
index 000000000000..2d3e4a72698e
--- /dev/null
+++ b/dev-python/six/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">six</remote-id>
+ <remote-id type="github">benjaminp/six</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/six/six-1.10.0.ebuild b/dev-python/six/six-1.10.0.ebuild
new file mode 100644
index 000000000000..8399fe544180
--- /dev/null
+++ b/dev-python/six/six-1.10.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 2 and 3 compatibility library"
+HOMEPAGE="https://github.com/benjaminp/six https://pypi.org/project/six/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+DEPEND="
+ doc? ( dev-python/sphinx )
+ test? ( >=dev-python/pytest-2.2.0[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/1.10.0-no-setuptools.patch
+ "${FILESDIR}"/1.9.0-mapping.patch
+)
+
+python_prepare_all() {
+ # https://bitbucket.org/gutworth/six/issues/139/
+ sed \
+ -e 's:test_assertCountEqual:_&:g' \
+ -e 's:test_assertRegex:_&:g' \
+ -e 's:test_assertRaisesRegex:_&:g' \
+ -i test_six.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C documentation html
+}
+
+python_test() {
+ py.test -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( documentation/_build/html/ )
+ distutils-r1_python_install_all
+}
+
+# Remove pkg_preinst in the next version bump
+pkg_preinst() {
+ # https://bugs.gentoo.org/585146
+ cd "${HOME}" || die
+
+ _cleanup() {
+ local pyver=$("${PYTHON}" -c "from distutils.sysconfig import get_python_version; print(get_python_version())")
+ local egginfo="${ROOT%/}$(python_get_sitedir)/${P}-py${pyver}.egg-info"
+ if [[ -d ${egginfo} ]]; then
+ echo rm -r "${egginfo}"
+ rm -r "${egginfo}" || die "Failed to remove egg-info directory"
+ fi
+ }
+ python_foreach_impl _cleanup
+}
diff --git a/dev-python/six/six-1.11.0.ebuild b/dev-python/six/six-1.11.0.ebuild
new file mode 100644
index 000000000000..7965dfe23b2d
--- /dev/null
+++ b/dev-python/six/six-1.11.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 2 and 3 compatibility library"
+HOMEPAGE="https://github.com/benjaminp/six https://pypi.org/project/six/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? ( >=dev-python/pytest-2.2.0[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/1.9.0-mapping.patch
+)
+
+python_compile_all() {
+ use doc && emake -C documentation html
+}
+
+python_test() {
+ py.test -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( documentation/_build/html/. )
+ distutils-r1_python_install_all
+}