summaryrefslogtreecommitdiff
path: root/dev-python/sip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/sip
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/Manifest2
-rw-r--r--dev-python/sip/sip-4.19.25.ebuild94
2 files changed, 96 insertions, 0 deletions
diff --git a/dev-python/sip/Manifest b/dev-python/sip/Manifest
index 43bbc98bb714..9ce801795adb 100644
--- a/dev-python/sip/Manifest
+++ b/dev-python/sip/Manifest
@@ -1,4 +1,6 @@
AUX sip-4.18-darwin.patch 1187 BLAKE2B a3cd0418de90e7377bc2ae1206f4620c6be379a3bd38f22c19256b06f5ba0c90ff07f34dcc8d2f44a25244e11544176a5e1b91049d220bd56cc7b3876a26ba76 SHA512 1afe049fd21f0e8e5118dec4d4b74851cd5e2c75a66a93e1a79a42267954b1edfcff9644696c7d98342499fb27fde727a554b5739cbd791d17a0e319c1dddb7e
DIST sip-4.19.24.tar.gz 1055461 BLAKE2B 6990b127a83fa57bc084eb9a1097f73c384b4fcf3d181479557fe2ffc66cde254bfbb5aef26f5ddd84dca346f54184952e7a111adf3b665f68571853e63b6575 SHA512 c9acf8c66da6ff24ffaeed254c11deabbc587cea0eb50164f2016199af30b85980f96a2d754ae5e7fe080f9076673b1abc82e2a6a41ff2ac442fb2b326fca1c0
+DIST sip-4.19.25.tar.gz 1056384 BLAKE2B f92e105e6b30e871aea2883dc9cd459e4032fb139a9eaff153a3412a66b39df4d7ac985711a2693aee83195ff3850ae648bee4102f7fc3cc30d09885799f2b98 SHA512 60fb4133c68869bf0993144978b4847d94a0f9c7b477f64a346ea133cfe35bc11820204ab327dcf9a929b6f65a26d16cc7efbce65e49967c3347b39376e57001
EBUILD sip-4.19.24.ebuild 2282 BLAKE2B d58ef24520a95ccb3a4f2113769a9187f2b1ea7172e6e63ae992565c20a413b7d3a8ad91f00c719a8117ed3ef5d4a23e717f21d026cd1a37fea07b95b222920a SHA512 005130da866237d4b391c2b516c1741e9544503adce8e61bea83a654649e3b1e073682eae29022d5e506476daf51b127fcb95279500306a096bc61cdf6910ce3
+EBUILD sip-4.19.25.ebuild 2288 BLAKE2B 0366fb84cf759be9ad8793649147f1a9443156b30bf2ee26b4a34887128c46b83e04af4a1602f8cac9e052ab810e3642326a8d48933477744f4242cd1892657a SHA512 0475e769a3a3868284bd75c66eaafc8d7f00c76715350cf7c25addbd03d5659f47a91b994410d531e0f8d2eafe9067c84da740a6c5812a39182e6771ba425a43
MISC metadata.xml 642 BLAKE2B 774d24a62fcf22158044669fd9981456a0b7512cc838cf15425239e9163c946adc5b01169d773167e98e4cc09a3c965b9a87b374048e3533b2140d35202e24ce SHA512 f6f3d30b416dfa71a5f3c245695ce958fc43a701a71f80968f06a0d21ec2c6387dcf505d8b3db1049b74ec8fb560e4a25547dad11365b23d78ed4e6f5769042b
diff --git a/dev-python/sip/sip-4.19.25.ebuild b/dev-python/sip/sip-4.19.25.ebuild
new file mode 100644
index 000000000000..c4e7e7947b40
--- /dev/null
+++ b/dev-python/sip/sip-4.19.25.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit python-r1 toolchain-funcs
+
+DESCRIPTION="Python extension module generator for C and C++ libraries"
+HOMEPAGE="https://www.riverbankcomputing.com/software/sip/intro"
+
+MY_PN=sip
+MY_P=${MY_PN}-${PV/_pre/.dev}
+if [[ ${PV} == *_pre* ]]; then
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+else
+ SRC_URI="https://www.riverbankcomputing.com/static/Downloads/${MY_PN}/${PV}/${MY_P}.tar.gz"
+fi
+
+# Sub-slot based on SIP_API_MAJOR_NR from siplib/sip.h
+SLOT="0/12"
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${PN}-4.18-darwin.patch )
+
+src_prepare() {
+ # Sub-slot sanity check
+ local sub_slot=${SLOT#*/}
+ local sip_api_major_nr=$(sed -nre 's:^#define SIP_API_MAJOR_NR\s+([0-9]+):\1:p' siplib/sip.h || die)
+ if [[ ${sub_slot} != ${sip_api_major_nr} ]]; then
+ eerror
+ eerror "Ebuild sub-slot (${sub_slot}) does not match SIP_API_MAJOR_NR (${sip_api_major_nr})"
+ eerror "Please update SLOT variable as follows:"
+ eerror " SLOT=\"${SLOT%%/*}/${sip_api_major_nr}\""
+ eerror
+ die "sub-slot sanity check failed"
+ fi
+
+ default
+}
+
+src_configure() {
+ configuration() {
+ local incdir=$(python_get_includedir)
+ local myconf=(
+ "${PYTHON}"
+ "${S}"/configure.py
+ --sysroot="${ESYSROOT}/usr"
+ --bindir="${EPREFIX}/usr/bin"
+ --destdir="$(python_get_sitedir)"
+ --incdir="${incdir#${SYSROOT}}"
+ AR="$(tc-getAR) cqs"
+ CC="$(tc-getCC)"
+ CFLAGS="${CFLAGS}"
+ CFLAGS_RELEASE=
+ CXX="$(tc-getCXX)"
+ CXXFLAGS="${CXXFLAGS}"
+ CXXFLAGS_RELEASE=
+ LINK="$(tc-getCXX)"
+ LINK_SHLIB="$(tc-getCXX)"
+ LFLAGS="${LDFLAGS}"
+ LFLAGS_RELEASE=
+ RANLIB=
+ STRIP=
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die
+ }
+ python_foreach_impl run_in_build_dir configuration
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installation() {
+ emake DESTDIR="${D}" install
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installation
+
+ einstalldocs
+ use doc && dodoc -r doc/html
+}