summaryrefslogtreecommitdiff
path: root/dev-python/simplejson
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /dev-python/simplejson
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/Manifest2
-rw-r--r--dev-python/simplejson/simplejson-3.15.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/simplejson/Manifest b/dev-python/simplejson/Manifest
index 0137c5633d95..6986f6b0b1ce 100644
--- a/dev-python/simplejson/Manifest
+++ b/dev-python/simplejson/Manifest
@@ -1,5 +1,7 @@
DIST simplejson-3.13.2.tar.gz 79735 BLAKE2B 5feb87611451054ad8e856e55a4a6bca50470f7f72692de9ce5abddf9eb214e29505124634d4d5a4f825366afe9a97614c66cbe14a73a4e57a5f2f62cac876e8 SHA512 ea29bc615de7fd0eb2a98f5dbeea74ee49b6fed6602396e77baf4480c86f975eff7fd868ac44f62a1c2f3721d4fa5b807b74109e5e28810df70dbad758110f41
DIST simplejson-3.14.0.tar.gz 80112 BLAKE2B 5866adeba886b4b4f526d4d7fb7ac65f12fa8cfe593a0ac40419c6f04e2f6b776adea49fdee861be54047666b7275bf229db7f7815515a9273878bf0eb68c5f5 SHA512 a81b20a75840566d5985803f35c56ee6957a433f0a9a6fc2f0fb2d46f978925cff0edc2f2c06fe85e7155c8301fbadc962152671c29310c6306f63afede75f98
+DIST simplejson-3.15.0.tar.gz 80963 BLAKE2B affa7da859bc2b2426389d881b53abdd086a2f7082decc9f8968859f54354d50747eb6f1cb8c4cc0151ef1e2cb8ecfb8aabd9f2151eaff2f39c4d08b9430f432 SHA512 601d575a5b8be66a33df28f27292ed12e5aeec39c74aa5a5108d82890dfb45a086e7a3a5072e012031209465c5c518909b4c1fb261fc055e6b9b1523a6bc39b4
EBUILD simplejson-3.13.2.ebuild 872 BLAKE2B cf3ce8bb8520a4d40e49209282b3a8a308aeccc16ce27cdf0ce9decf4592719e57840458b0dc7fae20fa774a078c71023f435a0db4aa460242b19eff1f68b39e SHA512 2a2a92b201a87144d442801aaca7dd6240ae97f4cd3ef39b88e98b4f469cfedfd5156e5f8aa7a9fac0f28e03ea363eaa1a50637ddfff9c8c003adcbb15fdcebc
EBUILD simplejson-3.14.0.ebuild 881 BLAKE2B 58e8e1b64333e861bfebef33ef1134f8cbb66cb82e724b489cb72b0b1771c9c5641f5b87b34bd3a346f6ef14905f02cadc6e5cd877d474959ad002f051158a52 SHA512 d1b7cdca473cbfebae39f4b88b52f462cb035fb9a3e7c69fa821158b12eed9515b6fb2ac26f0dc678f57ec24535796300b33ad26ed982c176f512bddce2348cd
+EBUILD simplejson-3.15.0.ebuild 881 BLAKE2B b8cc3a04d58387e66e56381e380fa302b72b60b58e0cda3fc31e6c7596d005012064251a638dd326b879e0d83864e4658f5d59b8ea053a6f85718ad11de85909 SHA512 f7d798b70bb20d290531d97d98e250d10c8b7f01a04edf647e6beabbb203397975bdd71934694b2c8b2b1f049423580743d097a190ae48af863a1a74bc1efadc
MISC metadata.xml 323 BLAKE2B c21be649394bb8a261a6169a710fd3862f1dd539505381a15f99611f323ea1e5fe4e6e54f1ed73d28bdddc2459812f13e40658ed99c09d0ba0f93f724b4bcfc9 SHA512 7db760ee80a6281bcc370303bafc40aea566465bf3264381336222c6f6002f573bfac205f2e42cca557c7b31855f082e1ed29ec9ab3b1125e455cf84bdaf54ec
diff --git a/dev-python/simplejson/simplejson-3.15.0.ebuild b/dev-python/simplejson/simplejson-3.15.0.ebuild
new file mode 100644
index 000000000000..becb68edb09f
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.15.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="https://github.com/simplejson/simplejson https://pypi.org/project/simplejson/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( README.rst CHANGES.txt )
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}