summaryrefslogtreecommitdiff
path: root/dev-python/simplejson/simplejson-3.19.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-01 16:14:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-01 16:14:02 +0100
commitaef01e7679692cb2cf9eca0c03865cfd0a4e33c9 (patch)
tree4a000095846b696df937b27f28c2483b902028c7 /dev-python/simplejson/simplejson-3.19.1.ebuild
parentfbf0c3d1b463bf45fb0e9f119bec3424d6a44a4f (diff)
gentoo auto-resync : 01:09:2023 - 16:14:02
Diffstat (limited to 'dev-python/simplejson/simplejson-3.19.1.ebuild')
-rw-r--r--dev-python/simplejson/simplejson-3.19.1.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-python/simplejson/simplejson-3.19.1.ebuild b/dev-python/simplejson/simplejson-3.19.1.ebuild
index 3d2130d9f7c4..a014c1d7ed9b 100644
--- a/dev-python/simplejson/simplejson-3.19.1.ebuild
+++ b/dev-python/simplejson/simplejson-3.19.1.ebuild
@@ -25,6 +25,8 @@ DOCS=( README.rst CHANGES.txt )
distutils_enable_tests unittest
src_configure() {
+ # native-extensions are always disabled on PyPy
+ # https://github.com/simplejson/simplejson/blob/master/setup.py#L121
export DISABLE_SPEEDUPS=$(usex native-extensions 0 1)
use native-extensions && export REQUIRE_SPEEDUPS=1
}