summaryrefslogtreecommitdiff
path: root/dev-python/simpervisor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-29 18:57:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-29 18:57:21 +0000
commit8455eae17683fbd2c785ca4b8443581622f388c7 (patch)
tree51bb7aac8b41b8f6e692f9e5b4e65001315b43fd /dev-python/simpervisor
parentb2f1788f6f0365b76f55f257b2d170c1e68a8640 (diff)
gentoo auto-resync : 29:01:2024 - 18:57:21
Diffstat (limited to 'dev-python/simpervisor')
-rw-r--r--dev-python/simpervisor/Manifest3
-rw-r--r--dev-python/simpervisor/files/simpervisor-1.0.0-yarl.patch28
-rw-r--r--dev-python/simpervisor/simpervisor-1.0.0-r1.ebuild (renamed from dev-python/simpervisor/simpervisor-1.0.0.ebuild)7
3 files changed, 36 insertions, 2 deletions
diff --git a/dev-python/simpervisor/Manifest b/dev-python/simpervisor/Manifest
index 09d414de7b7a..b09f79deb59c 100644
--- a/dev-python/simpervisor/Manifest
+++ b/dev-python/simpervisor/Manifest
@@ -1,3 +1,4 @@
+AUX simpervisor-1.0.0-yarl.patch 914 BLAKE2B 06a317c4fe6b464bcb7b920be870749949e1220739279fd3a347d833aff428188deab6d4dd1a09246a1d5b886496c5e37dd6f84b52f42ac02918811419046fc7 SHA512 327ba1fea64d1e178d5f5320e031c73e4ed5865f3c98694a94c7cc81905a8a5b06ead6df1308010765c5a4fc3c38adc5aea9b6e9568365a0fa303c2962de205e
DIST simpervisor-1.0.0.tar.gz 14637 BLAKE2B 3e87cca2478f29e044cafa0f5da6a5c8cfdf61f5c39ce87a0a6bae91670463d894e5c23af53c915b7d3469eade8d26947ea2e5c05c6d491bd33222e817319100 SHA512 0074ca5da0839f7bcf3f692f33f9a27358409bc194cfe04ff906aaec5f4cfbd613ccd285612ac473f5b6452a5c31959c098955a1962755a5c09258ded0d2a430
-EBUILD simpervisor-1.0.0.ebuild 584 BLAKE2B 38864adcda9c993d48f05ac365fd24011b98647fa8de14879cab4430fe2be10291340b887dce7d7664fc607471c07b5b169868fa441fca954a85e3d6438a78fc SHA512 b955e53cf2ae51c6d8292be86e1cc2ee62688ff8914328f0e80a1751c451a4dcabc0c66d7d92ee195b1fb4155316442121c69988fc139b70a7e1ef1808c33a28
+EBUILD simpervisor-1.0.0-r1.ebuild 681 BLAKE2B 753a138f7098e783a6f64ab3a3f4ce065ece9ca4c7190f1f5731360d2939b83b3a90b844cf0feb4b6221e0dfd8efeec2b2237d0fa427c418c4b7dc7ab8ff930c SHA512 189e2b095429e27c5cd52471fbcba6f7054af3434638eac63194664c3164bb5bfddb4117172f7685fc6f78b7767fff798e8f7334a2aff51faf152e15217be096
MISC metadata.xml 416 BLAKE2B 5a2eaeb468acd18ff9b8259bd8428aeb23292e06ad087f0fa9d7b4a3ffd340c8458fad980223b1b342225b518db8eea23af97f07079ae9a3518bb5a50d17edbf SHA512 2cf5e0a854134ed7de9418ba3f84e7a5708ca158021bcb3467b335a9b59686f034a152884e40aaf487b1f3f430f7404f8ed4e52f0192800400aa5cd32b31167d
diff --git a/dev-python/simpervisor/files/simpervisor-1.0.0-yarl.patch b/dev-python/simpervisor/files/simpervisor-1.0.0-yarl.patch
new file mode 100644
index 000000000000..5f884255262c
--- /dev/null
+++ b/dev-python/simpervisor/files/simpervisor-1.0.0-yarl.patch
@@ -0,0 +1,28 @@
+From b08f4b9b46009fb96c7194aecbc28d6b266e44c0 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Mon, 29 Jan 2024 18:14:32 +0100
+Subject: [PATCH] Convert `PORT` envvar to int to fix aiohttp/yarl
+ compatibility
+
+Conver the value of the `PORT` environment variable to int, to fix
+incompatibility with modern versions of aiohttp/yarl, that do expect
+the `port` argument to be one.
+
+Fixes #49
+---
+ tests/child_scripts/simplehttpserver.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/child_scripts/simplehttpserver.py b/tests/child_scripts/simplehttpserver.py
+index cc460ff..268dc7d 100644
+--- a/tests/child_scripts/simplehttpserver.py
++++ b/tests/child_scripts/simplehttpserver.py
+@@ -11,7 +11,7 @@
+ print("waiting", wait_time)
+ time.sleep(wait_time)
+
+-PORT = os.environ["PORT"]
++PORT = int(os.environ["PORT"])
+
+ routes = web.RouteTableDef()
+
diff --git a/dev-python/simpervisor/simpervisor-1.0.0.ebuild b/dev-python/simpervisor/simpervisor-1.0.0-r1.ebuild
index ac7a8e2d6665..344831934f52 100644
--- a/dev-python/simpervisor/simpervisor-1.0.0.ebuild
+++ b/dev-python/simpervisor/simpervisor-1.0.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,3 +27,8 @@ BDEPEND="
"
distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/jupyterhub/simpervisor/pull/50
+ "${FILESDIR}/${P}-yarl.patch"
+)