summaryrefslogtreecommitdiff
path: root/dev-python/simpervisor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-27 15:57:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-27 15:57:47 +0100
commit3cafd803b6d89f6e823358a8d7f4a97e6d0629e1 (patch)
tree0cec79ef55ddf2fcd790270ae08081a3e158f6e8 /dev-python/simpervisor
parentc70685892bc3f0b09aea1216ff278f6095f21281 (diff)
gentoo auto-resync : 27:10:2022 - 15:57:47
Diffstat (limited to 'dev-python/simpervisor')
-rw-r--r--dev-python/simpervisor/Manifest2
-rw-r--r--dev-python/simpervisor/simpervisor-0.4-r1.ebuild24
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/simpervisor/Manifest b/dev-python/simpervisor/Manifest
index aaa7f603f082..f2da4b8bc735 100644
--- a/dev-python/simpervisor/Manifest
+++ b/dev-python/simpervisor/Manifest
@@ -1,3 +1,5 @@
+DIST simpervisor-0.4.gh.tar.gz 8542 BLAKE2B bd96284b65468110f445e96a9978b67bc73b0a0f188dcaf592f42291937130e72247195b8ce142726ba430716b87283d844003bb0980de952531639417a23f50 SHA512 4aea0071d6a486c7b27fc39fa02d7b610d680c90ba07f3c27c3d98b132b79b97bcb5c7847ce9d3ca7bb46663f91494e0012c8c9e14017ca1c591fb6312419692
DIST simpervisor-0.4.tar.gz 8542 BLAKE2B bd96284b65468110f445e96a9978b67bc73b0a0f188dcaf592f42291937130e72247195b8ce142726ba430716b87283d844003bb0980de952531639417a23f50 SHA512 4aea0071d6a486c7b27fc39fa02d7b610d680c90ba07f3c27c3d98b132b79b97bcb5c7847ce9d3ca7bb46663f91494e0012c8c9e14017ca1c591fb6312419692
+EBUILD simpervisor-0.4-r1.ebuild 581 BLAKE2B 99fa545c6a20502f49af88b029740410c8f486ac92bff226e7c0f8a71235ddc6aa71691db1b1a79743ed9f42ab2ea7e90491b92aa58505e12a9a207b6556f4eb SHA512 e4744bf5571e0db36ef0ff0dceb849f453be7e516b9b24fe08ae58e7e36e1bd7a56aeb9d66c88723a97658eca6859c9101e87a3313276fcaf5acb43dbc9dbc1d
EBUILD simpervisor-0.4.ebuild 547 BLAKE2B 8554b7458dd15bebe92e2c3a88fb8a27571839e4824876688ae3ad2a63ceaadf57e4e34d935559002d71b222b7f3dd32d56d81c1b043a0d2cd2fb527889b3f5c SHA512 b4444dc16614432cea996ec8f52fe138630b2be7ae751f988d173bb7d2a376e44df1179926419aea0d6112ed893123df82d2d711f1819a9dc8e3ae7c1105b6ff
MISC metadata.xml 416 BLAKE2B 5a2eaeb468acd18ff9b8259bd8428aeb23292e06ad087f0fa9d7b4a3ffd340c8458fad980223b1b342225b518db8eea23af97f07079ae9a3518bb5a50d17edbf SHA512 2cf5e0a854134ed7de9418ba3f84e7a5708ca158021bcb3467b335a9b59686f034a152884e40aaf487b1f3f430f7404f8ed4e52f0192800400aa5cd32b31167d
diff --git a/dev-python/simpervisor/simpervisor-0.4-r1.ebuild b/dev-python/simpervisor/simpervisor-0.4-r1.ebuild
new file mode 100644
index 000000000000..086ec03866e8
--- /dev/null
+++ b/dev-python/simpervisor/simpervisor-0.4-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Simple Python3 Supervisor library"
+HOMEPAGE="https://github.com/jupyterhub/simpervisor"
+SRC_URI="https://github.com/jupyterhub/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest