summaryrefslogtreecommitdiff
path: root/dev-python/shtab/shtab-1.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-08 07:07:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-08 07:07:16 +0000
commitdc22a05dc2db2827053483e8cab136b33b339307 (patch)
tree3fd58204853fdb5a69c22ecfb0ce87e19aa91624 /dev-python/shtab/shtab-1.7.1.ebuild
parent443cfbefc0bbd1e252d323db7597b33ace434817 (diff)
gentoo auto-resync : 08:03:2024 - 07:07:16
Diffstat (limited to 'dev-python/shtab/shtab-1.7.1.ebuild')
-rw-r--r--dev-python/shtab/shtab-1.7.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/shtab/shtab-1.7.1.ebuild b/dev-python/shtab/shtab-1.7.1.ebuild
new file mode 100644
index 000000000000..3debac670a80
--- /dev/null
+++ b/dev-python/shtab/shtab-1.7.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Automagic shell tab completion for Python CLI applications"
+HOMEPAGE="
+ https://github.com/iterative/shtab
+ https://pypi.org/project/shtab/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-python/setuptools-scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Disable pytest-cov
+ epytest -o addopts=
+}