summaryrefslogtreecommitdiff
path: root/dev-python/shiboken2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/shiboken2
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/shiboken2')
-rw-r--r--dev-python/shiboken2/Manifest4
-rw-r--r--dev-python/shiboken2/shiboken2-5.15.1.ebuild (renamed from dev-python/shiboken2/shiboken2-5.14.2.ebuild)12
2 files changed, 8 insertions, 8 deletions
diff --git a/dev-python/shiboken2/Manifest b/dev-python/shiboken2/Manifest
index 34ec3d379645..d0605e7664f3 100644
--- a/dev-python/shiboken2/Manifest
+++ b/dev-python/shiboken2/Manifest
@@ -1,3 +1,3 @@
-DIST pyside-setup-opensource-src-5.14.2.tar.xz 3238036 BLAKE2B 454f19ae4e154747bad2b833727ab62ded15bbac495cc0bef112ce6cccdd69bb5bb541c9b31125bd05090bfce042bac2ac8b47690c695e82b5c901e45e87f681 SHA512 6708c4ebb115119796756ccac89197e111eb27c4a91f52875da04eff4ca6f9e3fffefc18cc0219a8c3a3c81a667bf7509909a6d1d9ff1ee2cc0d957453cceffa
-EBUILD shiboken2-5.14.2.ebuild 6621 BLAKE2B a16591525ff4396498d4d57c6f513b548ba5b39454927cc2b51ea108f390c0d4c981448a4200bcdd13c17a360134be540adcc3d93c14f305f230cd4461a9310a SHA512 90266606d682ac8543d8e4db03606b35e8cee17df9ec960836983d3947e901b14fd618bcea85842cf66a48ea1a27aa81971d937b5f3860bf94bf878a0c270bf6
+DIST pyside-setup-opensource-src-5.15.1.tar.xz 3454052 BLAKE2B c7190dff493434064976a4604fb5858d2e20c1b98098ccd6e5c4c69d0b67ae9f4bf970e2ab42b634208ea96aab31b21f3dfb5f18fddd0bdaab655bba729e4449 SHA512 f14c7037367799005fff73d9fc8e7998db1895700911adf34dfabdeb4db486c7b28ba2afb3eaee37c58f4099b00e4a86917b8f7d85f274026bddfc090658b306
+EBUILD shiboken2-5.15.1.ebuild 6585 BLAKE2B 9f180c3778fc96540bcfaef881fc8bd6ee8530f8eefcac546c3ce23534feba99bb13f40b170d4816ecea2256f4a0ba499f12018b06ffbd4c87c15656f4b025a4 SHA512 9671522a3dedc59a242c5c27d6710874d59557873d6fa4504e9472b62e66bf03578f383c8f0133aec0a05c5b704b6ec841bd90e88084c434395728bd501deb3b
MISC metadata.xml 503 BLAKE2B 37ba81030aa2393583ae7eece0a0f9a542d7bc7d4f2b8e8a434e366d7fc8a24045b6fa0bc667355cd36fcc9866333c30efaf5da026b567f02357dc69e411a202 SHA512 ab55f2d1d33be0746ff7a2056a6dcd774089d356f8162338f8f9071a03c5e6a2cd09d665aae2232b32c53ef9b50b86e7726210376ed38d981397c522620639bb
diff --git a/dev-python/shiboken2/shiboken2-5.14.2.ebuild b/dev-python/shiboken2/shiboken2-5.15.1.ebuild
index aa293aaad1eb..9877a168f1f4 100644
--- a/dev-python/shiboken2/shiboken2-5.14.2.ebuild
+++ b/dev-python/shiboken2/shiboken2-5.15.1.ebuild
@@ -14,7 +14,7 @@ EAPI=7
# https://bugreports.qt.io/browse/PYSIDE-535
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit cmake-utils llvm python-r1 toolchain-funcs
+inherit cmake llvm python-r1 toolchain-funcs
MY_P=pyside-setup-opensource-src-${PV}
@@ -103,7 +103,7 @@ src_prepare() {
ApiExtractor/clangparser/compilersupport.cpp || die
CPP="${_CPP_old}"
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -120,22 +120,22 @@ src_configure() {
-DUSE_PYTHON_VERSION="${EPYTHON#python}"
)
# CMakeLists.txt expects LLVM_INSTALL_DIR as an environment variable.
- LLVM_INSTALL_DIR="$(get_llvm_prefix)" cmake-utils_src_configure
+ LLVM_INSTALL_DIR="$(get_llvm_prefix)" cmake_src_configure
}
python_foreach_impl shiboken2_configure
}
src_compile() {
- python_foreach_impl cmake-utils_src_compile
+ python_foreach_impl cmake_src_compile
}
src_test() {
- python_foreach_impl cmake-utils_src_test
+ python_foreach_impl cmake_src_test
}
src_install() {
shiboken2_install() {
- cmake-utils_src_install
+ cmake_src_install
python_optimize
# Uniquify the "shiboken2" executable for the current Python target,