summaryrefslogtreecommitdiff
path: root/dev-python/shiboken2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-03 13:55:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-03 13:55:12 +0100
commit0a65aa74175d9ac6570321fe11725dc30c574e08 (patch)
tree72b20e59998ee19c32c86634c05e02790faaf20f /dev-python/shiboken2
parent4b4d352fc9761396c68812d8eccc63b7b14d6558 (diff)
gentoo auto-resync : 03:08:2022 - 13:55:12
Diffstat (limited to 'dev-python/shiboken2')
-rw-r--r--dev-python/shiboken2/Manifest3
-rw-r--r--dev-python/shiboken2/shiboken2-5.15.2-r1.ebuild172
-rw-r--r--dev-python/shiboken2/shiboken2-5.15.2-r2.ebuild2
3 files changed, 175 insertions, 2 deletions
diff --git a/dev-python/shiboken2/Manifest b/dev-python/shiboken2/Manifest
index 64534f88940c..0aef537c2d98 100644
--- a/dev-python/shiboken2/Manifest
+++ b/dev-python/shiboken2/Manifest
@@ -3,5 +3,6 @@ AUX shiboken2-5.15.2-python310.patch 4408 BLAKE2B cd1a5c3f8c473a6667f8c942c24828
AUX shiboken2-5.15.2-python311-fixups.patch 2059 BLAKE2B 746cc4c4f6f29895fc4c4d6989c2d578099f5d071129cf7b8dc78fef8641d10f189b4acf9293ae178cafe196d16cfce21e4e9d85a1ff7c107e9fc611b1dfea50 SHA512 8407f2b0166f8c3aed9bef3ecc8efc6177066c4a6148b8ff942f29b3e95752f15697a8447a58e51410d6982900e9e924d38be2a8857d7f15876badddbc37b507
AUX shiboken2-5.15.2-python311.patch 4606 BLAKE2B 40cc608b4dd5eb305809e2cd2fe2908e8f5a47dcf2a2e6efc92cbcf26604c50cd63b007d4e49b061f017a6675c57542b897fa019820a72adc4c291f798f6f01e SHA512 8403955111e8d9f9f9d8795668ab6cb19d83e9a2434593a4578905a065f706c5a4fede2f17c9e9acd8d2f9d5d0e64a54b6e65f512b147ee91f152430ac171c5b
DIST pyside-setup-opensource-src-5.15.2.tar.xz 3472624 BLAKE2B 099abeaf25059a88f299f90b18cf79aa45acd86580c0873767b09f76268d6746cc3576743a19493a605de59b520471ddee6bba0e5340801ef44a21f2a9d41507 SHA512 5043c1c9db4ba0133baaabb4d4943182e9741b1007bedd992394758707a37bba0688dc6413ea46620e7c2fb09daa3c74e6a7bb2c302b9d08e5f3bb7575d02b62
-EBUILD shiboken2-5.15.2-r2.ebuild 6554 BLAKE2B a4d2ba9ae4ff29d9b974b26a5c5c0c7db66790bab3433dab0b84e2c0465b08bd6c8a15df78ef342a8942472978c031cba809625286d619a0e3119e20e17bb27d SHA512 e0287e12b01024290b3b97103244bfcfb1e3385bc4e2d1fa4465894d6afc30dcaad50bd335bee4d26536d48db742c6aa0d924dce59d696721fedae747b09d01c
+EBUILD shiboken2-5.15.2-r1.ebuild 6551 BLAKE2B ba5cd749b4641a87c5d4edcf9c8e10d5c199dcd1f9888cd620b801f0d1e5c87d8988131011ecb5b4ea4077543f5a3c91bb5241ec21de091957b7e2cfe0b754bb SHA512 5a14af1ec01cd89b54652e6a1dfed547fcdccff6500ba221ab27796103605c5c9c16d812655478daa14be2fdc1e5a613223c44b9df67d47ef04a30882826e6b0
+EBUILD shiboken2-5.15.2-r2.ebuild 6557 BLAKE2B 4ea92a96a58d44bdc8a5108167d47e98d687334bbfd6e584822c11f4690b6f50b64f93c6bd71168fb4cf977a062e587c214629b53161f68ee2896148162d8b4a SHA512 140242eb4f4af1c609fab2ae3fd1f99d725a055af76fd5d565195481214548c80f9368a9b771cd82c848ff2e0aba61da39b2276595bd9a0eca4c878d0d989994
MISC metadata.xml 496 BLAKE2B 060c13ebf383e609b257f50f65484eecaaa1909d3b9242ab2be2b12ec203cdaaf4b5a9402f01b9e511b3744a4d7a562161d86a0d2f9bc90f401ac7ee0cea8ba4 SHA512 7edc53f2bde5d688e8dcac866997ec282cf2f7c1230a064a304c83a7b3c54c2079f99f4c75082dc47f7e9248dc65296ef98e0cda7dea08cbb97e766da48c11d5
diff --git a/dev-python/shiboken2/shiboken2-5.15.2-r1.ebuild b/dev-python/shiboken2/shiboken2-5.15.2-r1.ebuild
new file mode 100644
index 000000000000..c8e150bc7ed5
--- /dev/null
+++ b/dev-python/shiboken2/shiboken2-5.15.2-r1.ebuild
@@ -0,0 +1,172 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# TODO: Split the "/usr/bin/shiboken2" binding generator from the
+# "/usr/lib64/libshiboken2-*.so" family of shared libraries. The former
+# requires everything (including Clang) at runtime; the latter only requires
+# Qt and Python at runtime. Note that "pip" separates these two as well. See:
+# https://doc.qt.io/qtforpython/shiboken2/faq.html#is-there-any-runtime-dependency-on-the-generated-binding
+# Once split, the PySide2 ebuild should be revised to require
+# "/usr/bin/shiboken2" at build time and "libshiboken2-*.so" at runtime.
+# TODO: Add PyPy once officially supported. See also:
+# https://bugreports.qt.io/browse/PYSIDE-535
+# Fails to compile with python3.10
+# FAILED: libshiboken/CMakeFiles/libshiboken.dir/sbkstring.cpp.o
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake llvm python-r1 toolchain-funcs
+
+MY_P=pyside-setup-opensource-src-${PV}
+
+DESCRIPTION="Python binding generator for C++ libraries"
+HOMEPAGE="https://wiki.qt.io/PySide2"
+SRC_URI="https://download.qt.io/official_releases/QtForPython/pyside2/PySide2-${PV}-src/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P}/sources/shiboken2"
+
+# The "sources/shiboken2/libshiboken" directory is triple-licensed under the
+# GPL v2, v3+, and LGPL v3. All remaining files are licensed under the GPL v3
+# with version 1.0 of a Qt-specific exception enabling shiboken2 output to be
+# arbitrarily relicensed. (TODO)
+LICENSE="|| ( GPL-2 GPL-3+ LGPL-3 ) GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 x86"
+IUSE="+docstrings numpy test vulkan"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+#tests fail pretty bad and I'm not fixing them right now
+RESTRICT="test"
+
+# Minimal supported version of Qt.
+QT_PV="$(ver_cut 1-2):5"
+
+# Since Clang is required at both build- and runtime, BDEPEND is omitted here.
+RDEPEND="${PYTHON_DEPS}
+ >=dev-qt/qtcore-${QT_PV}
+ sys-devel/clang:=
+ sys-devel/clang-runtime:=
+ docstrings? (
+ >=dev-libs/libxml2-2.6.32
+ >=dev-libs/libxslt-1.1.19
+ >=dev-qt/qtxml-${QT_PV}
+ >=dev-qt/qtxmlpatterns-${QT_PV}
+ )
+ numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )
+ vulkan? ( dev-util/vulkan-headers )
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qttest-${QT_PV} )
+"
+
+DOCS=( AUTHORS )
+
+PATCHES=(
+ "${FILESDIR}/${P}-python310.patch"
+ "${FILESDIR}/${P}-numpy-1.23.patch"
+)
+
+# Ensure the path returned by get_llvm_prefix() contains clang as well.
+llvm_check_deps() {
+ has_version "sys-devel/clang:${LLVM_SLOT}"
+}
+
+src_prepare() {
+ # TODO: File upstream issue requesting a sane way to disable NumPy support.
+ if ! use numpy; then
+ sed -i -e '/\bprint(os\.path\.realpath(numpy))/d' \
+ libshiboken/CMakeLists.txt || die
+ fi
+
+ # Shiboken2 assumes Vulkan headers live under either "$VULKAN_SDK/include"
+ # or "$VK_SDK_PATH/include" rather than "${EPREFIX}/usr/include/vulkan".
+ if use vulkan; then
+ sed -i -e "s~\bdetectVulkan(&headerPaths);~headerPaths.append(HeaderPath{QByteArrayLiteral(\"${EPREFIX}/usr/include/vulkan\"), HeaderType::System});~" \
+ ApiExtractor/clangparser/compilersupport.cpp || die
+ fi
+
+ # Shiboken2 assumes the "/usr/lib/clang/${CLANG_NEWEST_VERSION}/include/"
+ # subdirectory provides Clang builtin includes (e.g., "stddef.h") for the
+ # currently installed version of Clang, where ${CLANG_NEWEST_VERSION} is
+ # the largest version specifier that exists under the "/usr/lib/clang/"
+ # subdirectory. This assumption is false in edge cases, including when
+ # users downgrade from newer Clang versions but fail to remove those
+ # versions with "emerge --depclean". See also:
+ # https://github.com/leycec/raiagent/issues/85
+ #
+ # Sadly, the clang-* family of functions exported by the "toolchain-funcs"
+ # eclass are defective, returning nonsensical placeholder strings if the
+ # end user has *NOT* explicitly configured their C++ compiler to be Clang.
+ # PySide2 does *NOT* care whether the end user has done so or not, as
+ # PySide2 unconditionally requires Clang in either case. See also:
+ # https://bugs.gentoo.org/619490
+ sed -i -e 's~(findClangBuiltInIncludesDir())~(QStringLiteral("'"${EPREFIX}"'/usr/lib/clang/'$(CPP=clang clang-fullversion)'/include"))~' \
+ ApiExtractor/clangparser/compilersupport.cpp || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Minimal tests for now, 2 failing with the extended version
+ # FIXME Subscripted generics cannot be used with class and instance checks
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ -DDISABLE_DOCSTRINGS=$(usex !docstrings)
+ )
+
+ shiboken2_configure() {
+ local mycmakeargs=(
+ "${mycmakeargs[@]}"
+ -DPYTHON_CONFIG_SUFFIX="-${EPYTHON}"
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DUSE_PYTHON_VERSION="${EPYTHON#python}"
+ )
+ # CMakeLists.txt expects LLVM_INSTALL_DIR as an environment variable.
+ local -x LLVM_INSTALL_DIR="$(get_llvm_prefix)"
+ cmake_src_configure
+ }
+ python_foreach_impl shiboken2_configure
+}
+
+src_compile() {
+ python_foreach_impl cmake_src_compile
+}
+
+src_test() {
+ python_foreach_impl cmake_src_test
+}
+
+src_install() {
+ shiboken2_install() {
+ cmake_src_install
+ python_optimize
+
+ # Uniquify the "shiboken2" executable for the current Python target,
+ # preserving an unversioned "shiboken2" file arbitrarily associated
+ # with the last Python target.
+ cp "${ED}"/usr/bin/${PN}{,-${EPYTHON}} || die
+
+ # Uniquify the Shiboken2 pkgconfig file for the current Python target,
+ # preserving an unversioned "shiboken2.pc" file arbitrarily associated
+ # with the last Python target. See also:
+ # https://github.com/leycec/raiagent/issues/73
+ cp "${ED}/usr/$(get_libdir)"/pkgconfig/${PN}{,-${EPYTHON}}.pc || die
+ }
+ python_foreach_impl shiboken2_install
+
+ # CMakeLists.txt installs a "Shiboken2Targets-gentoo.cmake" file forcing
+ # downstream consumers (e.g., PySide2) to target one "libshiboken2-*.so"
+ # library and one "shiboken2" executable linked to one Python interpreter.
+ # See also:
+ # https://bugreports.qt.io/browse/PYSIDE-1053
+ # https://github.com/leycec/raiagent/issues/74
+ sed -i \
+ -e 's~shiboken2-python[[:digit:]]\+\.[[:digit:]]\+~shiboken2${PYTHON_CONFIG_SUFFIX}~g' \
+ -e 's~/bin/shiboken2~/bin/shiboken2${PYTHON_CONFIG_SUFFIX}~g' \
+ "${ED}/usr/$(get_libdir)"/cmake/Shiboken2-${PV}/Shiboken2Targets-gentoo.cmake || die
+
+ # Remove the broken "shiboken_tool.py" script. By inspection, this script
+ # reduces to a noop. Moreover, this script raises the following exception:
+ # FileNotFoundError: [Errno 2] No such file or directory: '/usr/bin/../shiboken_tool.py': '/usr/bin/../shiboken_tool.py'
+ rm "${ED}"/usr/bin/shiboken_tool.py || die
+}
diff --git a/dev-python/shiboken2/shiboken2-5.15.2-r2.ebuild b/dev-python/shiboken2/shiboken2-5.15.2-r2.ebuild
index b022d8ba5b8c..4ba580569103 100644
--- a/dev-python/shiboken2/shiboken2-5.15.2-r2.ebuild
+++ b/dev-python/shiboken2/shiboken2-5.15.2-r2.ebuild
@@ -29,7 +29,7 @@ S="${WORKDIR}/${MY_P}/sources/shiboken2"
# arbitrarily relicensed. (TODO)
LICENSE="|| ( GPL-2 GPL-3+ LGPL-3 ) GPL-3"
SLOT="0"
-KEYWORDS="amd64 ~arm arm64 x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="+docstrings numpy test vulkan"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"