summaryrefslogtreecommitdiff
path: root/dev-python/sh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/sh
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/sh')
-rw-r--r--dev-python/sh/Manifest7
-rw-r--r--dev-python/sh/files/sh-1.12.9-python2-unicode-tests.patch22
-rw-r--r--dev-python/sh/metadata.xml22
-rw-r--r--dev-python/sh/sh-1.11-r1.ebuild25
-rw-r--r--dev-python/sh/sh-1.11.ebuild25
-rw-r--r--dev-python/sh/sh-1.12.9.ebuild29
6 files changed, 130 insertions, 0 deletions
diff --git a/dev-python/sh/Manifest b/dev-python/sh/Manifest
new file mode 100644
index 000000000000..5c37af748357
--- /dev/null
+++ b/dev-python/sh/Manifest
@@ -0,0 +1,7 @@
+AUX sh-1.12.9-python2-unicode-tests.patch 674 BLAKE2B 18153eb571fd50faf9c4e733b53f63f0630e7cd172eb5e5bdc04f550b49e247e9bdfecd6fc81868125c270e21899de29cc418e807d6b26df5ea8dd97a85d5b16 SHA512 c33cc195c54232dc7790aba2b34750f623a00ada51f55fc5da3ff9979f2c83359a904e47c0c3ded9f016ff256fafe5099be824261d91af0603f2d714c01e2342
+DIST sh-1.11.tar.gz 36821 BLAKE2B 30ac7cdb814b307c810190deea54f819d7ad3d134440040c5e0d1718b970331ec4764665f79784acf40b3905da074c19e9dd0338f7306e07d086a583dd058517 SHA512 ccaf178384b5a609c00bb44796a6bec088750414385f19b2d8ffcb93cc8f5ddb6bf82fb966d2bf519651f6efed54258a3c6542a9827d01e6be64af8cb8f86d3d
+DIST sh-1.12.9.tar.gz 54077 BLAKE2B 6a63a07fe82479388e5d84655d7a22d01fb2be2cb858884f2f69799aa3390443cbf7e6d42b640be6432239ab5d1a0db0b69f1e39bc3e30719dbba78c6fc8f5f0 SHA512 378ebfe148de6d1fb0f6488a42a39570f1fde6bb2d3ce40cbe29a6920e102f4c31d38a686663e52b2968099d85a0b5867e112c5d53ca0a4527a2f2bc9e607d35
+EBUILD sh-1.11-r1.ebuild 512 BLAKE2B 34ea9c6fe7d4548b3f830cc42d0f98b10271984c17787a84d2a012b7de340e58274bc149bd9c47efc89bba8d2f24d1f9d7ba4b03a6ffda1b4e2196bcb9c9dc21 SHA512 5b96da77018fe1f8b5104ad20e22affc65b4b7a10f55909891d1b7a06b80c89c5c27d4e8f63a4c8386e6c52f0a5cff16ba603cc9f539168e14f03e33562f7e5b
+EBUILD sh-1.11.ebuild 508 BLAKE2B c4c99294de47a10f8e7f877235d27c6166562b66e5d7fb4dba5b559809728f21b74333513c2ebfbce0cd55bf312376480382caec69245ac14441d109fc2cfedd SHA512 54f6375f364482039f95fedf21ce556b9daa94302b1e36a06b733025b16411b9f01bc538bde5456d4b99d95b3a163a85e49781031971cb6589729ddc0ea41726
+EBUILD sh-1.12.9.ebuild 580 BLAKE2B 3f9ab056e661f536bf6072127d4f19eb22938996fbcec6ca7aa52511e4543cf1ca5b74e6e023b85103e9d27bed85d43b2b25a62e96c2c828963c2237ee19be5f SHA512 4f03c4674f5b06a513ba95d71348c6641dab0d26e0081a984717a7b4815e4db5016c73e726c08c6a4afe6c4fec32b3b675fb5fe22116212032fa9ee965f868aa
+MISC metadata.xml 676 BLAKE2B 217e170b6b5cbfba2e5029c250dba3927f3cd2b3bbc5111cb5ea459fdcc1bcff0448a8dd2e4e2d8afe42f459e7a485fe4fe04202e9c253bd51f785eec216eb5a SHA512 4d4633de70608259eb2bb288af89992c90fe192258ac157d07f2d568922a88b497cf6a3e2961b266603089e55ce7cfcd7ae2831879ed9afce4c3c740479c2756
diff --git a/dev-python/sh/files/sh-1.12.9-python2-unicode-tests.patch b/dev-python/sh/files/sh-1.12.9-python2-unicode-tests.patch
new file mode 100644
index 000000000000..230b16ae5fb1
--- /dev/null
+++ b/dev-python/sh/files/sh-1.12.9-python2-unicode-tests.patch
@@ -0,0 +1,22 @@
+diff --git a/test.py b/test.py
+index 78e00ab..0487594 100644
+--- a/test.py
++++ b/test.py
+@@ -502,7 +502,7 @@ for key in osx_cruft:
+ print(os.environ["HERP"] + " " + str(len(os.environ)))
+ """ % osx_cruft)
+ out = python(py.name, _env=env).strip()
+- self.assertEqual(out, "DERP 1")
++ self.assertEqual(out, u"DERP 12")
+
+ py = create_tmp_test("""
+ import os, sys
+@@ -515,7 +515,7 @@ for key in osx_cruft:
+ print(sh.HERP + " " + str(len(os.environ)))
+ """ % osx_cruft)
+ out = python(py.name, _env=env, _cwd=THIS_DIR).strip()
+- self.assertEqual(out, "DERP 1")
++ self.assertEqual(out, u"DERP 12")
+
+
+ def test_which(self):
diff --git a/dev-python/sh/metadata.xml b/dev-python/sh/metadata.xml
new file mode 100644
index 000000000000..07e719850609
--- /dev/null
+++ b/dev-python/sh/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <longdescription lang="en">
+ sh (previously pbs) is a full-fledged subprocess interface
+ for Python 2.6 - 3.2 that allows you to call any program
+ as if it were a function:
+
+ from sh import ifconfig
+ print ifconfig("eth0")
+
+ sh is not a collection of system commands implemented in Python.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">sh</remote-id>
+ <remote-id type="github">amoffat/sh</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sh/sh-1.11-r1.ebuild b/dev-python/sh/sh-1.11-r1.ebuild
new file mode 100644
index 000000000000..9bc359e57766
--- /dev/null
+++ b/dev-python/sh/sh-1.11-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=(python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python subprocess interface"
+HOMEPAGE="https://github.com/amoffat/sh"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${PYTHON} test.py || die
+}
diff --git a/dev-python/sh/sh-1.11.ebuild b/dev-python/sh/sh-1.11.ebuild
new file mode 100644
index 000000000000..a4e9e8ae7468
--- /dev/null
+++ b/dev-python/sh/sh-1.11.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=(python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python subprocess interface"
+HOMEPAGE="https://github.com/amoffat/sh"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${PYTHON} test.py || die
+}
diff --git a/dev-python/sh/sh-1.12.9.ebuild b/dev-python/sh/sh-1.12.9.ebuild
new file mode 100644
index 000000000000..168127d102d9
--- /dev/null
+++ b/dev-python/sh/sh-1.12.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python subprocess interface"
+HOMEPAGE="https://github.com/amoffat/sh"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}/sh-1.12.9-python2-unicode-tests.patch"
+)
+
+python_test() {
+ ${PYTHON} test.py || die
+}