summaryrefslogtreecommitdiff
path: root/dev-python/setproctitle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/setproctitle
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/setproctitle')
-rw-r--r--dev-python/setproctitle/Manifest3
-rw-r--r--dev-python/setproctitle/files/setproctitle-1.2-pypy3.patch46
-rw-r--r--dev-python/setproctitle/setproctitle-1.2.ebuild21
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/setproctitle/Manifest b/dev-python/setproctitle/Manifest
index ff021c646440..ae31f288ed3c 100644
--- a/dev-python/setproctitle/Manifest
+++ b/dev-python/setproctitle/Manifest
@@ -1,3 +1,6 @@
+AUX setproctitle-1.2-pypy3.patch 1614 BLAKE2B e3aa1709da8c46f4ac6f6b66e587c860e29b3fb0571c7a0d209bf16a1815711e13d48ac6562f6ed7189d3c3f4cd670d4346a8e5ac077cc6f2d0f3ade93d48e97 SHA512 6991a4b224d4f467e70a54bd83fc474e5df00a050627f195720ce2d95d230582cd0b2c49b792a83334f2439de1df757c4a51070c495c275e133698132e7d79c9
DIST setproctitle-1.1.10.tar.gz 24042 BLAKE2B acd4ef33ab2a200b5d102fe5ceb78df03deeee47eb5a3c7b50f0a44e095953e5a4e2230278b6b4a5010472e4a5a18b81accbff0461e3a642be478b880d98114e SHA512 c976c5b86f59bc6d0f840f495b8256813169d3d7b9edae70207a24d62e1240bfec954fdc4f67b429ae124e3dc74efd7193404785643a52b2d57b55028bb3c533
+DIST setproctitle-1.2.tar.gz 23454 BLAKE2B 4a69566e48a2985ae8add0341feba26f062d8345dd773570e0500795e43b349777d4bf557bd8b88d9cec37850c129009823a1f87ed6261a9709e84c8a6f56868 SHA512 7dc84ac0fc028ca71e786622aa6b649961feb816e0f03a3d52ab7b1a5d7edc0c932695687f1f5487d27104535a3db0c48d12fd69859478a604dbf60c615f4e01
EBUILD setproctitle-1.1.10-r1.ebuild 980 BLAKE2B d6300fb90ba30c03d37afca61ccbc6fc04238ed1f279ebaffa8bdf9b3859fb7c469b1274dee5940261ee5db7bbc7ed772e103fa8b2ebf895617b568663e5b0e0 SHA512 af60bb769003e352e01b8c94bd8417f7c8c745059e24a322bdf5f32b8e3644f6f2d8246120cb60812f6a5588561b44c4753e15d4dd77ade2ecc781251a9a0aab
+EBUILD setproctitle-1.2.ebuild 641 BLAKE2B ce87b613f7fe566026005c06a2e511f39cb2d134e199944f4e8cca4cc25b757a2855fc5ac7e4efa72c6222f8ebeb1cfa1181abbf8e9caf25a5c8fde46f084b11 SHA512 51a8b22faeb1a1dc571752d7ed72aee0377670d52041ad5cf6baa8213050d3c174e1bf4b7f0bdd618512c64ed44bf1a00b6e057669d0bd243a9bc517a53b1621
MISC metadata.xml 380 BLAKE2B 136b22ffc942b2b6a6bcbd45ed3cebb105bf91a16014fa1fbc181a3a9055d132e03df3ffa63df79682f1e7369ee264f87ff32e8602a6478d170f4b20a230e9fe SHA512 eaca32091baa4a9fcd8ffbac6d250c135c0237552a7229aafc3cbb8bdf43450c114f26676964f80f73c2146b0b47934d77bdfdaf8411c069958bd898f69e8004
diff --git a/dev-python/setproctitle/files/setproctitle-1.2-pypy3.patch b/dev-python/setproctitle/files/setproctitle-1.2-pypy3.patch
new file mode 100644
index 000000000000..01d4b0e4dd53
--- /dev/null
+++ b/dev-python/setproctitle/files/setproctitle-1.2-pypy3.patch
@@ -0,0 +1,46 @@
+From b13b7254fa10b4ba461c03b0f1f03858a2368bdc Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Wed, 25 Nov 2020 09:29:18 +0100
+Subject: [PATCH] Fix skipping embedded tests with pypy
+
+Fix skipping embedded tests by using the 'skipif' decorator. The tests
+need to be skipped early, as otherwise they error out trying to
+initialize pyconfig fixture.
+---
+ tests/setproctitle_test.py | 8 ++------
+ 1 file changed, 2 insertions(+), 6 deletions(-)
+
+diff --git a/tests/setproctitle_test.py b/tests/setproctitle_test.py
+index 5d73733..7b679df 100644
+--- a/tests/setproctitle_test.py
++++ b/tests/setproctitle_test.py
+@@ -340,12 +340,10 @@ print(os.popen("ps -x -o pid,command 2> /dev/null").read())
+
+
+ @pytest.mark.embedded
++@pytest.mark.skipif(IS_PYPY, reason="skip test, pypy")
+ def test_embedded(pyrun, spt_directory):
+ """Check the module works with embedded Python.
+ """
+- if IS_PYPY:
+- pytest.skip("skip test, pypy")
+-
+ if not os.path.exists("/proc/%s/cmdline" % os.getpid()):
+ pytest.skip("known failure: '/proc/PID/cmdline' not available")
+
+@@ -371,11 +369,9 @@ print(os.popen("ps -x -o pid,command 2> /dev/null").read())
+
+
+ @pytest.mark.embedded
++@pytest.mark.skipif(IS_PYPY, reason="skip test, pypy")
+ def test_embedded_many_args(pyrun, spt_directory):
+ """Check more complex cmdlines are handled in embedded env too."""
+- if IS_PYPY:
+- pytest.skip("skip test, pypy")
+-
+ if not os.path.exists("/proc/%s/cmdline" % os.getpid()):
+ pytest.skip("known failure: '/proc/PID/cmdline' not available")
+
+--
+2.29.2
+
diff --git a/dev-python/setproctitle/setproctitle-1.2.ebuild b/dev-python/setproctitle/setproctitle-1.2.ebuild
new file mode 100644
index 000000000000..ca7098274771
--- /dev/null
+++ b/dev-python/setproctitle/setproctitle-1.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Allow customization of the process title"
+HOMEPAGE="https://github.com/dvarrazzo/py-setproctitle"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${P}-pypy3.patch
+)