summaryrefslogtreecommitdiff
path: root/dev-python/serpent/serpent-1.19.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/serpent/serpent-1.19.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/serpent/serpent-1.19.ebuild')
-rw-r--r--dev-python/serpent/serpent-1.19.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/serpent/serpent-1.19.ebuild b/dev-python/serpent/serpent-1.19.ebuild
new file mode 100644
index 000000000000..27e5ec56cd3d
--- /dev/null
+++ b/dev-python/serpent/serpent-1.19.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple serialization library based on ast.literal_eval"
+HOMEPAGE="https://pypi.python.org/pypi/serpent https://github.com/irmen/Serpent"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+# not bundled
+RESTRICT="test"
+
+python_test() {
+ pushd "${S}"/tests >/dev/null || die
+ ${PYTHON} -bb test_serpent.py || die
+ popd >/dev/null || die
+}