summaryrefslogtreecommitdiff
path: root/dev-python/sentry-sdk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-17 06:26:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-17 06:26:48 +0000
commit2e0bf408961ec1023d3db1fc5d687c233661ac26 (patch)
tree96c6e46af3c356d1fb470acdf72ada482bb293f8 /dev-python/sentry-sdk
parent48dbe17904ac8ee6f006488d8f21734b0d253db4 (diff)
gentoo auto-resync : 17:03:2023 - 06:26:48
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest2
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.17.0.ebuild106
2 files changed, 108 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index 630ee180bf7e..b1a74bf34a95 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,3 +1,5 @@
DIST sentry-python-1.16.0.gh.tar.gz 325763 BLAKE2B e53f6051a74065950c4f1ce9010a87071b4a715990643cb7e955411ffb784fabc7ca6f2ade3cc6c66eb0718c6fc4993c6035763a0937b8a1cd66289f3f026806 SHA512 7f46f6c66b0e4f97e7f64a0eba9c396fbb9ab95607ba8ecb4880bb117c4f3fff7881a6787ea814981bdfabd84ea2b172c878821877403852661e746b6fe666bb
+DIST sentry-python-1.17.0.gh.tar.gz 332229 BLAKE2B 5c94f80d8cbe9582fe03e948c74e37024c4d6fce4f6293bdb755ada0651c5a898db23826d23ed7e31845b7426c3f6a52014e0f4226b9810f13222a700e063f91 SHA512 e3f0b9287f703e36f55bb96f31a76638b99fc66f4cf6898ddcddeb57a5ee27a3d782815c9dae9cd1177ff7f5c606e62b7807adada1f841294f3b6d7449d950e1
EBUILD sentry-sdk-1.16.0.ebuild 3636 BLAKE2B 0a1659ddd0bc2f95875637270b637cda32fe557ac7471fed9b8c2518f0c51de97a542190d35d719d5fd13eebde63074fe6965d56e1100762b4cae16eddd26806 SHA512 c0de06866e1fe7b4594ff77ba3aa3291e9c8c7309aa2572a5c4dd4f799d42c85f7b7983f61fb74a0c443723bc4104482831465300b13cfa3d9af7b3ae8206ae8
+EBUILD sentry-sdk-1.17.0.ebuild 3640 BLAKE2B c3bd23007576bb9673782ef7ad4af56936c72f8b3c73e01bc86ce4436404066103532b0b358f82ae5b5058c9ec3c6e5b998eb54ca8245482a4aa819ebe2e2f0c SHA512 e0faee205c88e10a6abbf9eea5aea0d62d49031693a9a0aaed8fdbe9e5a075d719be897547fd3ac8ae296752030bb223cf8874958291a42421ab464273a9fedc
MISC metadata.xml 510 BLAKE2B e00011699ac2cc83f1923e1f6fa813ede7eab8c57f9ce9d9fca04e721b089db1c5f2bdffaa7b9856f56b433abd9189125e07ffd3f329e4fa8d098e28a4f2d7bd SHA512 bafb77a102d94fe050cb526b298fb8cfd56775cb4d07eda280f6356fbec6fbe5df5c9ebd459d9d4457cd027c2e0d7c349e053fa6070b52f0d2989f6ec600b87d
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.17.0.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.17.0.ebuild
new file mode 100644
index 000000000000..f02570ff1556
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-1.17.0.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=sentry-python-${PV}
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="
+ https://sentry.io/
+ https://github.com/getsentry/sentry-python/
+ https://pypi.org/project/sentry-sdk/
+"
+SRC_URI="
+ https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # tests require Internet access
+ tests/integrations/httpx/test_httpx.py
+ tests/integrations/requests/test_requests.py
+ tests/integrations/stdlib/test_httplib.py
+ tests/integrations/flask/test_flask.py
+ tests/integrations/django/test_basic.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # broken by rq-1.10.1 (optional dep)
+ tests/integrations/rq/test_rq.py
+ # fastapi is not packaged
+ tests/integrations/asgi/test_fastapi.py
+ # TODO
+ tests/integrations/bottle
+ # TODO: causes breakage in other tests
+ tests/integrations/starlette
+ # TODO
+ tests/integrations/tornado
+ # requires mockupdb
+ tests/integrations/pymongo
+)
+
+EPYTEST_DESELECT=(
+ # hangs
+ 'tests/test_transport.py::test_transport_works'
+ # TODO
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_client.py::test_databag_breadth_stripping
+ tests/integrations/asgi/test_asgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/asgi/test_asgi.py::test_websocket
+ tests/integrations/aiohttp/test_aiohttp.py::test_transaction_style
+ tests/integrations/aiohttp/test_aiohttp.py::test_traces_sampler_gets_request_object_in_sampling_context
+ # incompatible version?
+ tests/integrations/falcon/test_falcon.py
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_too_large_event_truncated
+ # test_circular_references: apparently fragile
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ # test for new feature, fails with IndexError
+ tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
+ # TODO
+ tests/integrations/wsgi/test_wsgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/wsgi/test_wsgi.py::test_profile_sent_when_profiling_enabled
+ tests/test_profiler.py::test_sample_buffer
+ tests/test_profiler.py::test_thread_scheduler_takes_first_samples
+ tests/test_profiler.py::test_thread_scheduler_takes_more_samples
+ tests/test_profiler.py::test_thread_scheduler_single_background_thread
+ # broken with py3.11, *shrug*
+ tests/test_profiler.py::test_extract_stack_with_max_depth
+ # TODO
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_long_sql_query_preserved
+)