summaryrefslogtreecommitdiff
path: root/dev-python/sentry-sdk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-python/sentry-sdk
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest2
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.5.0.ebuild76
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index 39b1037b651b..0f9627e02f49 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,3 +1,5 @@
DIST sentry-sdk-1.4.3.tar.gz 231054 BLAKE2B 39509b3f7b12e773e23881772cf2d3445374181f7bd23b3a7abe3cbdae012b03b43bcd4ce811a40cd2c7916cae378698ea5a53909b2f679d8b3f3598e675719e SHA512 bd5a1b75a437d28348f980cad0bad30cbcd2872fc9678e50d69bca73e0a08a8e663f0fd54607174122072dafad6055acc73db34c6ca92ec9d00efed41e5c1c97
+DIST sentry-sdk-1.5.0.tar.gz 233213 BLAKE2B f3debc106d1009eff09ae2acb1073d3a8244e39a746e063e869ee158a47a6542f485e8030515b1c633ca978950a4543c3a0ea4e2b1fb4408e478fde2d92bf33b SHA512 7cd9706749712ab55137b0eb05d100c42b9d644ffe76773ff97fc738ad3c1525b4381f8ea9168d8a87ee9932642837b542695bbe96bc2662a246a41368fd40d4
EBUILD sentry-sdk-1.4.3.ebuild 2384 BLAKE2B 528e2fa48742201bc1a71643a832ef712e254f3e884e08c3374c46f1006627fc983b3e52de2447189e5fa783f2decb75c9e654c5476a7d89a4576d8c36b7a739 SHA512 23f05193bcd03eb799e32e7356c22fd14c61fcc4fdcb4fd5b3a77027d126af114d27d2b9cc95fa72e25395baee3097fddf3943800e72486dc4492791b4cf39da
+EBUILD sentry-sdk-1.5.0.ebuild 2471 BLAKE2B b49d9a95db2f364cf538d4937db2bf5592858098e4d915a85d682e1961648a909fb993804dca5438eff15d2453b79b35bea1d2b3079fe139145cec5eac20b077 SHA512 758347aea2c1b199e454c0ca2585e58ec955ead0756554455643995895828d4b9254879db6c1bc6527b896581a50cf756381af881a2c008fd9a89e7234e958bc
MISC metadata.xml 510 BLAKE2B e00011699ac2cc83f1923e1f6fa813ede7eab8c57f9ce9d9fca04e721b089db1c5f2bdffaa7b9856f56b433abd9189125e07ffd3f329e4fa8d098e28a4f2d7bd SHA512 bafb77a102d94fe050cb526b298fb8cfd56775cb4d07eda280f6356fbec6fbe5df5c9ebd459d9d4457cd027c2e0d7c349e053fa6070b52f0d2989f6ec600b87d
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.5.0.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.5.0.ebuild
new file mode 100644
index 000000000000..ffb7c607d135
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-1.5.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="https://sentry.io/ https://pypi.org/project/sentry-sdk/"
+SRC_URI="https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/sentry-python-${PV}"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # tests require Internet access
+ tests/integrations/httpx/test_httpx.py
+ tests/integrations/requests/test_requests.py
+ tests/integrations/stdlib/test_httplib.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ )
+
+ local EPYTEST_DESELECT=(
+ # hangs
+ 'tests/test_transport.py::test_transport_works'
+ # TODO
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_client.py::test_databag_breadth_stripping
+ # incompatible version?
+ tests/integrations/falcon/test_falcon.py
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_too_large_event_truncated
+ # test_circular_references: apparently fragile
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ # test for new feature, fails with IndexError
+ tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
+ )
+
+ # Prevent tests/integrations/modules/test_modules.py:test_basic failure
+ # Needs to detect sentry-sdk in the installed modules
+ distutils_install_for_testing
+
+ epytest
+}