summaryrefslogtreecommitdiff
path: root/dev-python/sentry-sdk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-11 10:29:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-11 10:29:19 +0100
commitf9a53aec073578673710687755db617717dd87d3 (patch)
tree9e9642aae0c5bc25cac799d6a2437229bbb76a76 /dev-python/sentry-sdk
parent7e110ec617b903791c3d309845e11a8b27f441cc (diff)
gentoo auto-resync : 11:07:2023 - 10:29:18
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest2
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.28.0.ebuild118
2 files changed, 120 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index b80d0e9a89ba..91384be9d135 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,6 +1,8 @@
AUX sentry-sdk-1.21.0-ignore-warnings.patch 329 BLAKE2B cdb4295e600d868feb11b4a0af534bca90a1fa777344d56c945ddcfe71b3db10848df4032df06b9acf84cf574bec04dce4dc8935dd7421a6d0a2a011db337d6f SHA512 d1b5c50c78d1bb299280c4937fc8a8fdfc7d174d41061a32b57178c4dee58ab4b4b7afe8566a6b79244e53be8714b3ee7fdc9bf3401835d6d743e9fdc5a0aa05
DIST sentry-python-1.26.0.gh.tar.gz 371531 BLAKE2B cdc44a8c4067405242b7aaec28999902df8ac7938d933ec8f5c050b6659bf5f920d7422dbe712813de995308fd49ce6173ca59e346d5a8912f6c3452f6063fb2 SHA512 de1d1c4af1d629c7689691d99ebd0acd3c023fc07fcfc6e706e7738b536601186ce33672b85ba08123f430923bb0c67cdbe0e56c9642d2219df55c8f1d14f07d
DIST sentry-python-1.27.1.gh.tar.gz 376598 BLAKE2B 4ad5986af5e252cf501523fcafdaa7ada4870aae0252227907d86ce3e886b58f7154f4407cb6ae22473044589c9c2639c7de8ca92dea1a7a7835c51c28b44bb6 SHA512 1408c06b3b8a8ef0c888f26a4591d45b63fda51853e52f2ea8921e4983d0a7b05b053c6bf17d55fc59667e5b4b4ca953419303774101fa58ef6f37428d600c90
+DIST sentry-python-1.28.0.gh.tar.gz 378626 BLAKE2B 826257c5cae7d1f58753d4a84fb7aeb0fb9d52690a660615590cdd34c7d1afe1e256291d9434f904644292d6ab379fcad03cc7d8b1072e3b41b03fb5e4961db6 SHA512 83ceecbf89f197c03b0a402508c677eed4c6adb36ff826579513f79dd36c666e47267c7b6e8f4eced91fc12b18a0de3c1a24c89c6fe6e77c603ace535612542c
EBUILD sentry-sdk-1.26.0.ebuild 4166 BLAKE2B 7e72178c20ab82082c4f59f9f407f8b217064457449967bfeec95725e9cf85d173abadc094cbd4c5a91858dd90645d701aad8273a8d0a6148d65b1711fb9a62a SHA512 2d208dbcb9e0f6c0e5f3c259e8a3737a5090ff0b4324c78d6c2b94b7824946096325cc1e5cb28b3e79700992a5190755a0843801e0dbbe88bbde3a84853e0b9e
EBUILD sentry-sdk-1.27.1.ebuild 4170 BLAKE2B b9ab88af5992582b939280c483bfdc2ac2c2a72f14fa398023ba94700d2be4e6c23734850430fdd5ba77ffeeeb913bd492d84b0ff0a1ecd6bb5ce3b72a76b93c SHA512 314e5bb7acdd79b8ad8d119aa7e96aeb14e06d2d95073efc97a1dc471123632300479d79d261f8f34a13cffa3266f34cabaca7e0d31b6915e4f0b6f74c5e4f00
+EBUILD sentry-sdk-1.28.0.ebuild 4170 BLAKE2B b9ab88af5992582b939280c483bfdc2ac2c2a72f14fa398023ba94700d2be4e6c23734850430fdd5ba77ffeeeb913bd492d84b0ff0a1ecd6bb5ce3b72a76b93c SHA512 314e5bb7acdd79b8ad8d119aa7e96aeb14e06d2d95073efc97a1dc471123632300479d79d261f8f34a13cffa3266f34cabaca7e0d31b6915e4f0b6f74c5e4f00
MISC metadata.xml 510 BLAKE2B e00011699ac2cc83f1923e1f6fa813ede7eab8c57f9ce9d9fca04e721b089db1c5f2bdffaa7b9856f56b433abd9189125e07ffd3f329e4fa8d098e28a4f2d7bd SHA512 bafb77a102d94fe050cb526b298fb8cfd56775cb4d07eda280f6356fbec6fbe5df5c9ebd459d9d4457cd027c2e0d7c349e053fa6070b52f0d2989f6ec600b87d
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.28.0.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.28.0.ebuild
new file mode 100644
index 000000000000..1335788113ac
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-1.28.0.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_11 )
+
+inherit distutils-r1
+
+MY_P=sentry-python-${PV}
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="
+ https://sentry.io/
+ https://github.com/getsentry/sentry-python/
+ https://pypi.org/project/sentry-sdk/
+"
+SRC_URI="
+ https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/python-socks[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/sentry-sdk-1.21.0-ignore-warnings.patch"
+)
+
+EPYTEST_IGNORE=(
+ # tests require Internet access
+ tests/integrations/httpx/test_httpx.py
+ tests/integrations/requests/test_requests.py
+ tests/integrations/stdlib/test_httplib.py
+ tests/integrations/flask/test_flask.py
+ tests/integrations/django/test_basic.py
+ tests/integrations/socket/test_socket.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # broken by rq-1.10.1 (optional dep)
+ tests/integrations/rq/test_rq.py
+ # fastapi is not packaged
+ tests/integrations/asgi/test_fastapi.py
+ # TODO
+ tests/integrations/bottle
+ # TODO: causes breakage in other tests
+ tests/integrations/starlette
+ # TODO
+ tests/integrations/tornado
+ # requires mockupdb
+ tests/integrations/pymongo
+)
+
+EPYTEST_DESELECT=(
+ # hangs
+ 'tests/test_transport.py::test_transport_works'
+ # TODO
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_client.py::test_databag_breadth_stripping
+ tests/integrations/asgi/test_asgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/asgi/test_asgi.py::test_websocket
+ tests/integrations/aiohttp/test_aiohttp.py::test_transaction_style
+ tests/integrations/aiohttp/test_aiohttp.py::test_traces_sampler_gets_request_object_in_sampling_context
+ tests/integrations/django/test_data_scrubbing.py::test_scrub_django_custom_session_cookies_filtered
+ # incompatible version?
+ tests/integrations/falcon/test_falcon.py
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_large_event_not_truncated
+ # test_circular_references: apparently fragile
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ # test for new feature, fails with IndexError
+ tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
+ # TODO
+ tests/integrations/wsgi/test_wsgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/wsgi/test_wsgi.py::test_profile_sent_when_profiling_enabled
+ tests/test_profiler.py::test_sample_buffer
+ tests/test_profiler.py::test_thread_scheduler_takes_first_samples
+ tests/test_profiler.py::test_thread_scheduler_takes_more_samples
+ tests/test_profiler.py::test_thread_scheduler_single_background_thread
+ # broken with py3.11, *shrug*
+ tests/test_profiler.py::test_extract_stack_with_max_depth
+ # TODO
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_long_sql_query_preserved
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_engine_name_not_string
+ tests/test_scrubber.py::test_breadcrumb_extra_scrubbing
+ tests/test_scrubber.py::test_span_data_scrubbing
+ # this is not even funny
+ tests/integrations/modules/test_modules.py::test_installed_modules
+)