summaryrefslogtreecommitdiff
path: root/dev-python/sentry-sdk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-04 01:15:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-04 01:15:40 +0100
commitc1bd8495f43d1e8a084ac779db6e4623aaa8d6ad (patch)
treee149dfa502bb9b798db46039ff95a0ed656a5567 /dev-python/sentry-sdk
parentab6ac5a7942816b5b14186dc53e1b17ea7df200a (diff)
gentoo auto-resync : 04:10:2022 - 01:15:40
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest2
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.9.10.ebuild96
2 files changed, 98 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index 90c1a8ed4de2..6ad19f2dbf7b 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,6 +1,8 @@
+DIST sentry-sdk-1.9.10.gh.tar.gz 282661 BLAKE2B dbecfafafebb52f288ff977dc39b7268c0cd7fc78a643139b9baf9345eb216842bad426e860914dad325096306dc515bf48ddfb26f524c95c718787ecadce3e1 SHA512 293f38335692fe6ec215d470b436d2a8ae49ac8471722c555405e920a41d2d591682c956bb01ad43bb3705566353a878f8fabfe74248716e9cf5a2ea2c172649
DIST sentry-sdk-1.9.7.gh.tar.gz 270209 BLAKE2B d1671bb45efa8aa785dc33a5d27e1d44843000809a88c4b081bbaca31be9ece65c6b192cadd46df912e1e1ca8650c7246f9946adb85117e88d13446965e190ac SHA512 d5c9a32e2c4001892cd03357d3b0cfe4c789eb0f4a12f6431920624795d4ed70a4055351541e12d9ee0be6e0fa689190e53c05fac53a27dad30e9f9fbe0711c1
DIST sentry-sdk-1.9.8.gh.tar.gz 271425 BLAKE2B 27135f4fee24d80a544d852261555d8a8498990f815bbe7438b67bbf5717ed4b6e92c8f3e6781929332cbaba75986538294cf4b97c5bbe845ab57a32333d1d6f SHA512 7c9136b4100537e327ccbc2a96967007a1d2de653098ffa3463cc135ca604e49bd066d6a85046c752f38bdfc2698298e46a5d26bbf1a31a19f1631cf92ad9c8d
DIST sentry-sdk-1.9.9.gh.tar.gz 281232 BLAKE2B 8d1017644c2ae73c4e070f7b1b0a6807ab1d7a7655986bb9a4b457f72c98b3df0fd5f3af8722ea91e13911b1ce6d7234542af195a0b80ec5e9e939f5de3998f0 SHA512 613b504c9e0071657241c7724206d3e99f62fdc846cda98fa4830cf29eee24c8d2ae2abb265fab5d87f47d064d8aed60e105c2d2090fb24308e65b7e74e2974b
+EBUILD sentry-sdk-1.9.10.ebuild 3205 BLAKE2B cc50ae93fdb72f81c15ac975cb7359056feba2eb1f67b77335892f784be8f859bc5125fc341f370eaa4b1b3526387fb12246046b1b0d9db52d364f796c440236 SHA512 e78cbc57645b20a02a691cca4849f9728d95eaa10fc55ac035111b50b24b1d8766875a66db0306256b446c2a47a797d2d890ed11ffc1246e6cea43e243b97379
EBUILD sentry-sdk-1.9.7.ebuild 3201 BLAKE2B 371fb9d17f8f843c34c17857d68818de5e04c40267a1009ccb98fc2bcabcb67d80d9da36bab08962224936bcfa1c230be10ab88758a0bc4713f4ec68ad28b2a0 SHA512 fb5f857923833a77c952da761c6b4b8ab88037c981f5468913c83d22ce119026814f57b9902e72b21ab21ddbf83b12e60e707c340ed91aa5a39b5269515e3dd8
EBUILD sentry-sdk-1.9.8.ebuild 3205 BLAKE2B cc50ae93fdb72f81c15ac975cb7359056feba2eb1f67b77335892f784be8f859bc5125fc341f370eaa4b1b3526387fb12246046b1b0d9db52d364f796c440236 SHA512 e78cbc57645b20a02a691cca4849f9728d95eaa10fc55ac035111b50b24b1d8766875a66db0306256b446c2a47a797d2d890ed11ffc1246e6cea43e243b97379
EBUILD sentry-sdk-1.9.9.ebuild 3205 BLAKE2B cc50ae93fdb72f81c15ac975cb7359056feba2eb1f67b77335892f784be8f859bc5125fc341f370eaa4b1b3526387fb12246046b1b0d9db52d364f796c440236 SHA512 e78cbc57645b20a02a691cca4849f9728d95eaa10fc55ac035111b50b24b1d8766875a66db0306256b446c2a47a797d2d890ed11ffc1246e6cea43e243b97379
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.9.10.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.9.10.ebuild
new file mode 100644
index 000000000000..9d1e2042e8f2
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-1.9.10.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="
+ https://sentry.io/
+ https://github.com/getsentry/sentry-python/
+ https://pypi.org/project/sentry-sdk/
+"
+SRC_URI="
+ https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/sentry-python-${PV}"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ ' python3_{8..9})
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # tests require Internet access
+ tests/integrations/httpx/test_httpx.py
+ tests/integrations/requests/test_requests.py
+ tests/integrations/stdlib/test_httplib.py
+ tests/integrations/flask/test_flask.py
+ tests/integrations/django/test_basic.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # broken by rq-1.10.1 (optional dep)
+ tests/integrations/rq/test_rq.py
+ # fastapi is not packaged
+ tests/integrations/asgi/test_fastapi.py
+ # TODO
+ tests/integrations/bottle
+ # requires python-multipart (TODO: package it)
+ tests/integrations/starlette
+)
+
+EPYTEST_DESELECT=(
+ # hangs
+ 'tests/test_transport.py::test_transport_works'
+ # TODO
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_client.py::test_databag_breadth_stripping
+ tests/integrations/asgi/test_asgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/asgi/test_asgi.py::test_websocket
+ tests/integrations/aiohttp/test_aiohttp.py::test_transaction_style
+ tests/integrations/aiohttp/test_aiohttp.py::test_traces_sampler_gets_request_object_in_sampling_context
+ # incompatible version?
+ tests/integrations/falcon/test_falcon.py
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_too_large_event_truncated
+ # test_circular_references: apparently fragile
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ # test for new feature, fails with IndexError
+ tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
+ # TODO
+ tests/integrations/wsgi/test_wsgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/wsgi/test_wsgi.py::test_profile_sent_when_profiling_enabled
+)