summaryrefslogtreecommitdiff
path: root/dev-python/send2trash/send2trash-1.8.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-07 06:30:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-07 06:30:50 +0100
commit7336b11bd5bd8f1cc6d445b150a6c466736c3d9d (patch)
tree7cd86e52a1c0068c146d765abfd47bdaeb0c00d0 /dev-python/send2trash/send2trash-1.8.3.ebuild
parentd749d42b2ef572969f0b7fb5016888f25cc28a8d (diff)
gentoo auto-resync : 07:04:2024 - 06:30:49
Diffstat (limited to 'dev-python/send2trash/send2trash-1.8.3.ebuild')
-rw-r--r--dev-python/send2trash/send2trash-1.8.3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/send2trash/send2trash-1.8.3.ebuild b/dev-python/send2trash/send2trash-1.8.3.ebuild
new file mode 100644
index 000000000000..816b76361a12
--- /dev/null
+++ b/dev-python/send2trash/send2trash-1.8.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=Send2Trash
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sends files to the Trash (or Recycle Bin)"
+HOMEPAGE="
+ https://github.com/arsenetar/send2trash/
+ https://pypi.org/project/Send2Trash/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest