summaryrefslogtreecommitdiff
path: root/dev-python/semver/semver-3.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-03 05:19:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-03 05:19:36 +0100
commit155cc74ccaea367efa88c8acfadcf25cb7dfe89c (patch)
tree7c071f2c978804bd5ad135f096c2c1849d338b6f /dev-python/semver/semver-3.0.0.ebuild
parentd288197c01703f58dbea0ff4f42b01e7c4c6f327 (diff)
gentoo auto-resync : 03:04:2023 - 05:19:36
Diffstat (limited to 'dev-python/semver/semver-3.0.0.ebuild')
-rw-r--r--dev-python/semver/semver-3.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/semver/semver-3.0.0.ebuild b/dev-python/semver/semver-3.0.0.ebuild
new file mode 100644
index 000000000000..bf44d18fbd00
--- /dev/null
+++ b/dev-python/semver/semver-3.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python module for semantic versioning"
+HOMEPAGE="
+ https://github.com/python-semver/python-semver/
+ https://pypi.org/project/semver/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}