summaryrefslogtreecommitdiff
path: root/dev-python/semver/semver-2.13.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-17 08:06:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-17 08:06:58 +0000
commit29394d0921808a94a409f01eff49f681651de5d5 (patch)
tree93d18027cb4ea68a3c967602c5793af032180bab /dev-python/semver/semver-2.13.0-r1.ebuild
parent5987fa693ef880163ebde423615a177cb5bda20e (diff)
gentoo auto-resync : 17:02:2023 - 08:06:58
Diffstat (limited to 'dev-python/semver/semver-2.13.0-r1.ebuild')
-rw-r--r--dev-python/semver/semver-2.13.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/semver/semver-2.13.0-r1.ebuild b/dev-python/semver/semver-2.13.0-r1.ebuild
new file mode 100644
index 000000000000..f534300fab4d
--- /dev/null
+++ b/dev-python/semver/semver-2.13.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="A Python module for semantic versioning"
+HOMEPAGE="https://github.com/python-semver/python-semver"
+SRC_URI="https://github.com/python-${PN}/python-${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/python-${P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # contains pytest/cov args we don't want
+ rm setup.cfg || die
+ distutils-r1_python_prepare_all
+}