summaryrefslogtreecommitdiff
path: root/dev-python/semantic_version/semantic_version-2.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/semantic_version/semantic_version-2.9.0.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/semantic_version/semantic_version-2.9.0.ebuild')
-rw-r--r--dev-python/semantic_version/semantic_version-2.9.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/semantic_version/semantic_version-2.9.0.ebuild b/dev-python/semantic_version/semantic_version-2.9.0.ebuild
new file mode 100644
index 000000000000..b164d12e692a
--- /dev/null
+++ b/dev-python/semantic_version/semantic_version-2.9.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library providing a few tools handling SemVer in Python"
+HOMEPAGE="https://pypi.org/project/semantic-version/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~riscv ~sparc x86"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:django
+}