summaryrefslogtreecommitdiff
path: root/dev-python/scrypt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/scrypt
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/scrypt')
-rw-r--r--dev-python/scrypt/Manifest5
-rw-r--r--dev-python/scrypt/metadata.xml19
-rw-r--r--dev-python/scrypt/scrypt-0.8.0.ebuild26
-rw-r--r--dev-python/scrypt/scrypt-0.8.6.ebuild22
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/scrypt/Manifest b/dev-python/scrypt/Manifest
new file mode 100644
index 000000000000..d1b23d42c7e1
--- /dev/null
+++ b/dev-python/scrypt/Manifest
@@ -0,0 +1,5 @@
+DIST scrypt-0.8.0.tar.gz 39042 BLAKE2B 305973f0093fd3f9f132c448a5155c58f7306df31912c909401cccb224b89a7458fa72a4f659c37bfb81f31daae92797624fbabf7de723bf2869eb92af333853 SHA512 2619b6af84b1bb5b9586af3a0a903baf606985357ff7db34612b032aba65e002998a727882657f19bff6c7a987125d9b2d8daebbe0ba3717f3dfa6650975e52b
+DIST scrypt-0.8.6.tar.gz 52986 BLAKE2B dbf9f28e03dbe8f37696c6d227dfc719d3952d3182ddba49fd6c2aaf34e53db4a84a412ccec1ac8c83abaa5c12c6d6bb36107cf90a60a5776b1a9f596d1f85f3 SHA512 f0f3bd61a5fcb55a1d6af5b7062202446c2c0595e88617f1e53c4ded6a9b1ab857fda9e8d153c0b3bbceee49a818dd428776522c6b0919b15096fd230b13ef60
+EBUILD scrypt-0.8.0.ebuild 613 BLAKE2B 3238d5824f5faac5741abcfc88d3b04e7a35e8f9ec3211a16af24b5bd03b2d1d59d9ae9949b7a7314ab53792a5a898acb9dcc67c125884003b61d7b78c9e90d8 SHA512 94827254f58aa4649b01ff46a8ee2266e7bc462324b06a06627e8cfa68cd317d939ad2a173a5f98faa151fc5dad2f418a3ef3376c84ad3c2953e2ba465685501
+EBUILD scrypt-0.8.6.ebuild 553 BLAKE2B ed66ad16c07f6fa054c1c224a702e256e1097734c1561d7523e215bc7a6fee34be029a1d0ec217125d5f67e4560a352bc1945b40f7447bc3d13a953c8bc8c473 SHA512 70718f0674da03f7c323b4039798b57b0af5400b8a15665449a3ce166470d3ecd4f2855bd2229158b911ab4c37e04a67575bcd7524c6dc172527438c64259d8c
+MISC metadata.xml 586 BLAKE2B a5f49db551f2768d1474c483127fb555d0015d59896d3016c4036cf19d719c4f996c31f2f3bea9bf92c0e4d8d21979dfeb917974727944c16eab40a3bd15e82f SHA512 67277df1509df252e7366080edf19500697aad8ffe6192839f61fea76391803525ca05c377e8d1f1b67d606e47fc7047b4714f55a2cc9166642329a4af4cb92c
diff --git a/dev-python/scrypt/metadata.xml b/dev-python/scrypt/metadata.xml
new file mode 100644
index 000000000000..2a0ca5a44135
--- /dev/null
+++ b/dev-python/scrypt/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Bindings for the scrypt key derivation function library
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">scrypt</remote-id>
+ <remote-id type="bitbucket">mhallin/py-scrypt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/scrypt/scrypt-0.8.0.ebuild b/dev-python/scrypt/scrypt-0.8.0.ebuild
new file mode 100644
index 000000000000..e8a275ed3604
--- /dev/null
+++ b/dev-python/scrypt/scrypt-0.8.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Bindings for the scrypt key derivation function library"
+HOMEPAGE="https://bitbucket.org/mhallin/py-scrypt/wiki/Home/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+KEYWORDS="amd64 ~arm ~arm64 x86"
+SLOT="0"
+IUSE="test doc"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# dist tarball does not have tests
+RESTRICT=test
+
+python_test() {
+ esetup.py test || die "tests failed"
+}
diff --git a/dev-python/scrypt/scrypt-0.8.6.ebuild b/dev-python/scrypt/scrypt-0.8.6.ebuild
new file mode 100644
index 000000000000..97ae828ae6b8
--- /dev/null
+++ b/dev-python/scrypt/scrypt-0.8.6.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Bindings for the scrypt key derivation function library"
+HOMEPAGE="https://bitbucket.org/mhallin/py-scrypt/wiki/Home/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+SLOT="0"
+IUSE="test doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test || die "tests failed"
+}