summaryrefslogtreecommitdiff
path: root/dev-python/scipy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-26 19:33:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-26 19:33:08 +0100
commite52012895af4c92f008daac78c3d8b6d691a5dd1 (patch)
tree23cfaf6724a2a4437945e792ce42481a83acfd4a /dev-python/scipy
parente41409e9c4ccf0cd1b45b81f9d2370d13326cfc2 (diff)
gentoo auto-resync : 26:06:2023 - 19:33:07
Diffstat (limited to 'dev-python/scipy')
-rw-r--r--dev-python/scipy/Manifest3
-rw-r--r--dev-python/scipy/scipy-1.11.0.ebuild124
2 files changed, 127 insertions, 0 deletions
diff --git a/dev-python/scipy/Manifest b/dev-python/scipy/Manifest
index bfffe5dddb0e..d0d430224d93 100644
--- a/dev-python/scipy/Manifest
+++ b/dev-python/scipy/Manifest
@@ -1,4 +1,7 @@
DIST scipy-1.10.1.tar.gz 42407997 BLAKE2B 807dceb1e056a1a2c0ec354e4e21f64e59cdab9eaf286cec3783bb93bf80efa00a71e7bd8d1898e8a2fdf86b614f035a0a97436dc4515574d73d9d4521824316 SHA512 767e1dee6285d98e4d58d8d8d1e3654b00e3216e9ad55455fc9473f1d044bef80ecce749bcd24d8f331367b882c9c3e6b652a6e901bb4296ddc7cc44699215b6
+DIST scipy-1.11.0.tar.gz 56030121 BLAKE2B e700bf8f9cffa7bc0f4832722010dcf2e03d8f93d13534f7f85734394c02536c1427cae5a097b59616f0873ba941579fcf2efd0baafc2037d9eca1f93362d38b SHA512 248cfbbedba73925b0461bf0f96c4a11bd4cfc7849cb18c58f6405074796ab0efdc4f056c58d344cb8833c0d2c6425f84e7ac6fe958cf98b1cc0bf16e7ff2444
DIST scipy-html-1.10.1.zip 49191107 BLAKE2B 5163ae3a62745992bcf94ab02ca2bb13fcf6d2ae0eb2a113ba29bc37a8e8f40ec70e39fe16e6371ce0bc31d4c8f0f46746be91b4fe2ad41c68a985c6f00fb8e7 SHA512 f3252452d3bfd400890f29460de2f97bf72732e0fc864582e906b78808e856ead5b1bf97cba531f2150e396408e585499d127004231421d20108e96040316232
+DIST scipy-html-1.11.0.zip 50421508 BLAKE2B cb5e4a4f8817a80f54ae73b4a47ba22d2438df46ebfe27ef5fdc2695fdd983226f4ccae925bf82b15d01ced4f4b6807384ecadac5e1aa7700aa887ad06b7d065 SHA512 33718bbd5e828687d93fccc441a53b6a2e8f54ac4952d3b69d4c4668f55cb6ef5aba33df9acda20b2400effa5ae71767b2a5602a365ad2045a6edd24ff89c253
EBUILD scipy-1.10.1.ebuild 2662 BLAKE2B dec183f49fdfc327173ad0a5ae329cf9621662f08f116a16d3048004b1de25e535b0ba5edaad8c21ffee328cbdc9eb233f2494dc99ab24a687bb21ca7699925a SHA512 ee9bf4e78a98402d4ea0658af6d45428144a5ddca988583421abc1d992ac7e38c3ef3dab4500ac09ac103c6e5e7190c7d4e1d7036bbe26c4572463edfbefc066
+EBUILD scipy-1.11.0.ebuild 2788 BLAKE2B 5ed5993b046a177228cc67096e20dacd5ba760f94db41d3df741b3473858ccc3828f272b880fe004824084d13775be17b4c57487f78bd703461a983ead7a2ccd SHA512 8d0cd0d692fe8b4c2575810e5a9cbc3eebe7db4f54d10521e5bd023dc9e0a596ee689c016cf9b1c5a93d5fbb9ce08cf6fc1edce12638cd225cbcd5a94c3a2586
MISC metadata.xml 953 BLAKE2B a09ea1325a175e349fbc3ca77c5e7b373538ea01147e8544f44b7d4e0c55fbbc2012431fcfe9a3457e82d295e4b5630df1ed69c48ef3462ed9b157af30a1e09a SHA512 74a21c6e1a9bef95b3d74a9513c59d302f473725c04fa32a9991b6108113c0f4b78179ce4a628140e7aa870c24ca60bddf7a00063b6b73dd45110112311371d8
diff --git a/dev-python/scipy/scipy-1.11.0.ebuild b/dev-python/scipy/scipy-1.11.0.ebuild
new file mode 100644
index 000000000000..10bd746dd9b0
--- /dev/null
+++ b/dev-python/scipy/scipy-1.11.0.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FORTRAN_NEEDED=fortran
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=meson-python
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit fortran-2 distutils-r1 multiprocessing
+
+DESCRIPTION="Scientific algorithms library for Python"
+HOMEPAGE="
+ https://scipy.org/
+ https://github.com/scipy/scipy/
+ https://pypi.org/project/scipy/
+"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+
+ # Need submodules, so git for now.
+ EGIT_REPO_URI="https://github.com/scipy/scipy"
+ EGIT_BRANCH="maintenance/$(ver_cut 1-2).x"
+ EGIT_SUBMODULES=( '*' )
+else
+ inherit pypi
+
+ # Upstream is often behind with doc updates
+ DOC_PV=${PV}
+
+ SRC_URI+="
+ doc? (
+ https://docs.scipy.org/doc/${PN}-${DOC_PV}/${PN}-html-${DOC_PV}.zip
+ )"
+
+ if [[ ${PV} != *rc* ]] ; then
+ KEYWORDS="~amd64 ~arm ~arm64 -hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ fi
+fi
+
+LICENSE="BSD LGPL-2"
+SLOT="0"
+IUSE="doc +fortran test-rust"
+
+# umfpack is technically optional but it's preferred to have it available.
+DEPEND="
+ >=dev-python/numpy-1.21.6[lapack,${PYTHON_USEDEP}]
+ sci-libs/arpack:=
+ sci-libs/umfpack
+ virtual/cblas
+ >=virtual/lapack-3.8
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/pillow[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-lang/swig
+ >=dev-python/cython-0.29.35[${PYTHON_USEDEP}]
+ >=dev-python/meson-python-0.12.1[${PYTHON_USEDEP}]
+ >=dev-python/pybind11-2.10.4[${PYTHON_USEDEP}]
+ >=dev-util/meson-1.1.0
+ dev-util/patchelf
+ virtual/pkgconfig
+ doc? ( app-arch/unzip )
+ fortran? ( dev-python/pythran[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+ test-rust? (
+ dev-python/pooch[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_unpack() {
+ default
+
+ if use doc; then
+ unzip -qo "${DISTDIR}"/${PN}-html-${DOC_PV}.zip -d html || die
+ fi
+}
+
+python_configure_all() {
+ DISTUTILS_ARGS=(
+ -Dblas=blas
+ -Dlapack=lapack
+ -Duse-pythran=$(usex fortran true false)
+ )
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+
+ local EPYTEST_DESELECT=(
+ # Network
+ scipy/datasets/tests/test_data.py::TestDatasets::test_existence_all
+ scipy/datasets/tests/test_data.py::TestDatasets::test_ascent
+ scipy/datasets/tests/test_data.py::TestDatasets::test_face
+ scipy/datasets/tests/test_data.py::TestDatasets::test_electrocardiogram
+
+ # Precision issue with diff. blas?
+ scipy/optimize/tests/test__basinhopping.py::Test_Metropolis::test_gh7799
+ )
+ local EPYTEST_IGNORE=()
+
+ if ! has_version -b "dev-python/pooch[${PYTHON_USEDEP}]" ; then
+ EPYTEST_IGNORE+=(
+ scipy/datasets/tests/test_data.py
+ )
+ fi
+
+ epytest -n "$(makeopts_jobs)" scipy
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${WORKDIR}"/html/. )
+
+ distutils-r1_python_install_all
+}