summaryrefslogtreecommitdiff
path: root/dev-python/scipy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /dev-python/scipy
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'dev-python/scipy')
-rw-r--r--dev-python/scipy/Manifest2
-rw-r--r--dev-python/scipy/scipy-1.6.3.ebuild9
2 files changed, 9 insertions, 2 deletions
diff --git a/dev-python/scipy/Manifest b/dev-python/scipy/Manifest
index 39df78a7a2e0..ed842e4a13d7 100644
--- a/dev-python/scipy/Manifest
+++ b/dev-python/scipy/Manifest
@@ -5,5 +5,5 @@ DIST scipy-html-1.6.2.zip 23947380 BLAKE2B e4616a157c037b0830fc32d23678fb7e8ebe0
DIST scipy-ref-1.6.1.pdf 34594740 BLAKE2B 905ddcd7a3d462b09ded688f0818204d7684fa18058d0dac480d0a000e9ea0b7ebcdd33c01adae17234dcdf630d4aef9078174127af46f1db55d5c14b3245346 SHA512 355f4681439c1720f45dca6badfe72d77edfca0962fd9b42df34f1cd8fff7121fa6e7f60570bb638abd3ba9693930fa46b25af862d8fc1568b508c6fdd785479
DIST scipy-ref-1.6.2.pdf 34599668 BLAKE2B 9ae3221c814eb0d1b1e9191e08000955af503f6448cf8b5841e400fad106c658670339219f4838bd312023601776fe0b0d123ebbd41460c478145da2ac3e9989 SHA512 9aecb7ca760805c470c41121268281c9547aef35ddf078816c5e48f7cf4912a67cf622e267152c6cc823df9d82be1f3a875d97469169d0d91d6219164c130c88
EBUILD scipy-1.6.2.ebuild 4145 BLAKE2B 5ff8d9071dcea9ab487dc253717939110d1e79a41492b0172a504ba14c1da81126aafdfb16312d88ad54e8f26f73f4e4ad289bf455b3c56d3186bab926f721a0 SHA512 d020e73bd5bf44f2a0aadb1a34e61d93dcaab2d1a68e50cfcc101f88b61ebcd10404efa7e2570d839143f9683b5b8e9bfc9a3645d01c710250d1ef1d1bdd0be0
-EBUILD scipy-1.6.3.ebuild 4162 BLAKE2B ee3da32f74b2b4d878992cf95ec069ad296e248c46770a0bb0464c30afb8a3fd568aaa933b8fc2bf4586242ce5b5e127fd3f55278de4e479d3207a6be5eeb4a1 SHA512 3e43ab96a8c7592088667368a05bd312521cd76d1f2c03ffa2c35f2c7c693035e93d92f14e8884261157bf06b88a82378ac4948f8ee5af42ec7e6bdb0b9571a1
+EBUILD scipy-1.6.3.ebuild 4366 BLAKE2B fd4b6ed960d8cce4f035fc978bdc2270cc00480a292a9e3fca3d711b4f0361d3ad308d9c1a492c9faf1cfaee44ec12f457822650e88eccb2269307e3d8eaba4b SHA512 e57644101d43a91c8184778e965177df158d2a6844dd271cf049ce992a6e86d046ad215534cf3741148c24749845326cb6c0030ab8f93c7a000fdb05046a325a
MISC metadata.xml 1039 BLAKE2B 74d7919c947e4efbeb597dba51ce74b9e2ef995a1e06c0db7fc7c13dcfd0c175afd0b9bce04907274e4eeab2dfcc49f0eca81ab71f76873817f3b9a1ca8ca196 SHA512 c0024d9accbb563f13ba22b32c95881118fec0ec0a68ce498a39d6bc63e13cf2c7db903132481e3b4d085757c5aba8bb4959780d67fd33db5b161a149e18c643
diff --git a/dev-python/scipy/scipy-1.6.3.ebuild b/dev-python/scipy/scipy-1.6.3.ebuild
index e98e4bd93794..8dec73bd4f25 100644
--- a/dev-python/scipy/scipy-1.6.3.ebuild
+++ b/dev-python/scipy/scipy-1.6.3.ebuild
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="threads(+)"
-inherit fortran-2 distutils-r1 flag-o-matic multiprocessing toolchain-funcs
+inherit fortran-2 distutils-r1 flag-o-matic toolchain-funcs
# upstream is slacking forever with doc updates
DOC_PV=1.6.2
@@ -108,6 +108,13 @@ python_prepare_all() {
sed -e "s:== 'levy_stable':in ('levy_stable', 'crystalball', 'ncf'):" \
-i scipy/stats/tests/test_continuous_basic.py || die
+ if has_version ">=sci-libs/lapack-3.10"; then
+ sed -e 's:test_sort(:_&:' \
+ -i scipy/linalg/tests/test_decomp.py || die
+ sed -e 's:test_solve_discrete_are:_&:' \
+ -i scipy/linalg/tests/test_solvers.py || die
+ fi
+
distutils-r1_python_prepare_all
}