summaryrefslogtreecommitdiff
path: root/dev-python/scipy/scipy-1.14.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-28 07:59:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-28 07:59:59 +0100
commitb8325835c82367d22428eb41afa0f2d375338d3c (patch)
treec416b8853bd14fc346da5d0129843cc4a68a30a0 /dev-python/scipy/scipy-1.14.0.ebuild
parentd2ed973482fdd800013658e83a61709b29e0a80f (diff)
gentoo auto-resync : 28:06:2024 - 07:59:59
Diffstat (limited to 'dev-python/scipy/scipy-1.14.0.ebuild')
-rw-r--r--dev-python/scipy/scipy-1.14.0.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/dev-python/scipy/scipy-1.14.0.ebuild b/dev-python/scipy/scipy-1.14.0.ebuild
index a37f5c5245cb..8e3a14e3952c 100644
--- a/dev-python/scipy/scipy-1.14.0.ebuild
+++ b/dev-python/scipy/scipy-1.14.0.ebuild
@@ -6,10 +6,10 @@ EAPI=8
FORTRAN_NEEDED=fortran
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=meson-python
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
PYTHON_REQ_USE="threads(+)"
-inherit fortran-2 distutils-r1
+inherit flag-o-matic fortran-2 distutils-r1
DESCRIPTION="Scientific algorithms library for Python"
HOMEPAGE="
@@ -95,6 +95,9 @@ python_configure_all() {
-Duse-pythran=$(usex fortran true false)
)
+ # https://bugs.gentoo.org/932721
+ has_version '>=dev-python/numpy-2.0.0' && filter-lto
+
# hide real scipy, to prevent pythran crashing when scipy is being
# rebuilt for new numpy ABI
# https://github.com/serge-sans-paille/pythran/issues/2194
@@ -157,6 +160,12 @@ python_test() {
scipy/optimize/tests/test_hessian_update_strategy.py::TestHessianUpdateStrategy::test_initialize_catch_illegal
)
;;
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # docstring formatting
+ scipy/misc/tests/test_doccer.py::test_decorator
+ )
+ ;;
esac
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1