summaryrefslogtreecommitdiff
path: root/dev-python/scipy/scipy-1.10.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-25 18:13:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-25 18:13:05 +0100
commitc7b5a281b2f19df584053abc11abb47ccad9c381 (patch)
tree982904bec5cf328955b044b4aa3a0788ff5fbc01 /dev-python/scipy/scipy-1.10.1.ebuild
parent403ab7c9007c3a5ff376f2a5d8963c5db58813fb (diff)
gentoo auto-resync : 25:04:2023 - 18:13:05
Diffstat (limited to 'dev-python/scipy/scipy-1.10.1.ebuild')
-rw-r--r--dev-python/scipy/scipy-1.10.1.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/dev-python/scipy/scipy-1.10.1.ebuild b/dev-python/scipy/scipy-1.10.1.ebuild
index fbe608eae076..c04548669025 100644
--- a/dev-python/scipy/scipy-1.10.1.ebuild
+++ b/dev-python/scipy/scipy-1.10.1.ebuild
@@ -4,6 +4,7 @@
EAPI=8
FORTRAN_NEEDED=fortran
+DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=meson-python
PYTHON_COMPAT=( python3_{9..11} )
PYTHON_REQ_USE="threads(+)"
@@ -93,28 +94,24 @@ python_configure_all() {
}
python_test() {
- cd "${T}" || die
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
local EPYTEST_DESELECT=(
- linalg/tests/test_decomp.py::TestSchur::test_sort
- linalg/tests/test_solvers.py::test_solve_discrete_are
- optimize/tests/test_milp.py::test_milp_timeout_16545
-
# Network
- datasets/tests/test_data.py::TestDatasets::test_existence_all
- datasets/tests/test_data.py::TestDatasets::test_ascent
- datasets/tests/test_data.py::TestDatasets::test_face
- datasets/tests/test_data.py::TestDatasets::test_electrocardiogram
+ scipy/datasets/tests/test_data.py::TestDatasets::test_existence_all
+ scipy/datasets/tests/test_data.py::TestDatasets::test_ascent
+ scipy/datasets/tests/test_data.py::TestDatasets::test_face
+ scipy/datasets/tests/test_data.py::TestDatasets::test_electrocardiogram
)
local EPYTEST_IGNORE=()
if ! has_version -b "dev-python/pooch[${PYTHON_USEDEP}]" ; then
EPYTEST_IGNORE+=(
- datasets/tests/test_data.py
+ scipy/datasets/tests/test_data.py
)
fi
- epytest -n "$(makeopts_jobs)" --pyargs scipy
+ epytest -n "$(makeopts_jobs)" scipy
}
python_install_all() {