summaryrefslogtreecommitdiff
path: root/dev-python/scikit-build-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-12 10:31:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-12 10:31:55 +0100
commiteb3ae345f026de053870dfa589779989d300ebef (patch)
tree1bea6ba3fbb1dca4db8c0cf9d9025d1e3e26f96a /dev-python/scikit-build-core
parent0e24de4e7c207a09710001af8230df7892eb73d4 (diff)
gentoo auto-resync : 12:07:2023 - 10:31:55
Diffstat (limited to 'dev-python/scikit-build-core')
-rw-r--r--dev-python/scikit-build-core/Manifest1
-rw-r--r--dev-python/scikit-build-core/scikit-build-core-0.4.7.ebuild48
2 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/scikit-build-core/Manifest b/dev-python/scikit-build-core/Manifest
index 59c98fd57ca4..b4a4341d728d 100644
--- a/dev-python/scikit-build-core/Manifest
+++ b/dev-python/scikit-build-core/Manifest
@@ -1,5 +1,4 @@
AUX scikit-build-core-0.4.7-setuptools-hooks.patch 1289 BLAKE2B 628510dd9638190ca4dae89c3b2dced2a2986a43bc556aa078162f22da5e4976064ee3058b220d3ab2f4f9fe8f7d26f51287b08e1af97504eb15c97f83313e75 SHA512 ea5c0837e363d0a62bd492056f4efee5abbfbc234ea32049c411dd794f3cbf6bb4c6d7dc77cb4337c6a164342d99b4e0de0bd96209512dd01ac1626a76e1980d
DIST scikit_build_core-0.4.7.tar.gz 161024 BLAKE2B a06136ca6144305290dcebacd33690556ce30c28793572adfd7b42b043d4bb7f2e6e8000fcb543608d33a130f7094683a31870aa40067fb24fbb453fed884ccf SHA512 39f99facc920e3a46a3592d15ce9f3ceb90cf92dca8a010546a9cc15d50ea7737951286b6474f2f3f68f206f4fa7d157931fcfa831e122f51266df56ec5f043e
EBUILD scikit-build-core-0.4.7-r1.ebuild 1252 BLAKE2B 5a37c30fce41b4db4c357d54ec3891edbd248593cdee06ad2af5f870a3ea6f37293b5b3c5aaf8b636c37550bbccaa568e6641c350c7d18b45c65b037ac4ce9ab SHA512 56bab5fde5d23e58fbf4b8f0ce45734c4d1674586e40dfef1f5c52a4640c1147f229776c4376f9958bcf2f3fd27c588c6e5ad64697eecc2c3ce61d6e38d6cfba
-EBUILD scikit-build-core-0.4.7.ebuild 1196 BLAKE2B cc7aa554ac04d64b84c59c81f11aa07c503a740e57955adb142b79efca1797ccecab104af2a9664f368cea60512e9c26815637b7fe16a4367453c15b457fd3e4 SHA512 3f2a3d7ff1df60b2214a88e54820f7da0a7fcfef4f75514d9c14e206c2fa3fce6100ba17e06aae1aa5449f2b9884ce98bd69ef9db13f2896cc75014081c479d3
MISC metadata.xml 393 BLAKE2B 25bdc0bc295ed4bd7cd76a5a6952cb7fa5d5a404d3260562f2ed322d80f2466add0373a2a6b10a41c4dc2211e82e0a680735301d8844e70a54760301b4ab190f SHA512 176537f2027aedb3bc8bd16bbbcde8bfed246d621763e22a979f2942c016e1bafa5ef2d11d8d078e5d59970ea115864a8501185343bc3d4b9fd8493adbd16aab
diff --git a/dev-python/scikit-build-core/scikit-build-core-0.4.7.ebuild b/dev-python/scikit-build-core/scikit-build-core-0.4.7.ebuild
deleted file mode 100644
index 9cf9fc3a704b..000000000000
--- a/dev-python/scikit-build-core/scikit-build-core-0.4.7.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Build backend for CMake based projects"
-HOMEPAGE="
- https://github.com/scikit-build/scikit-build-core/
- https://pypi.org/project/scikit-build-core/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-# we always want [pyproject] extra
-RDEPEND="
- >=dev-python/packaging-20.9[${PYTHON_USEDEP}]
- >=dev-python/pathspec-0.10.1[${PYTHON_USEDEP}]
- >=dev-python/pyproject-metadata-0.5[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/exceptiongroup[${PYTHON_USEDEP}]
- >=dev-python/tomli-1.1[${PYTHON_USEDEP}]
- ' 3.9 3.10)
-"
-BDEPEND="
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
- test? (
- dev-python/build[${PYTHON_USEDEP}]
- >=dev-python/cattrs-22.2.0[${PYTHON_USEDEP}]
- dev-python/pybind11[${PYTHON_USEDEP}]
- >=dev-python/pytest-subprocess-1.5[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- epytest -m "not isolated and not network"
-}