summaryrefslogtreecommitdiff
path: root/dev-python/scikit-build-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-24 10:45:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-24 10:45:40 +0000
commit1804d2ae908b26fe4e3d3a38646c7d6ffa733d92 (patch)
tree6f5cdff53cb2fde48a01817379124dc476b3742d /dev-python/scikit-build-core
parent2fa0c8dbba3b2455531e5616eed64f2fe66cb58b (diff)
gentoo auto-resync : 24:01:2024 - 10:45:40
Diffstat (limited to 'dev-python/scikit-build-core')
-rw-r--r--dev-python/scikit-build-core/Manifest2
-rw-r--r--dev-python/scikit-build-core/scikit-build-core-0.8.0.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/scikit-build-core/Manifest b/dev-python/scikit-build-core/Manifest
index b8eb3cc5b3f6..b55abc14d798 100644
--- a/dev-python/scikit-build-core/Manifest
+++ b/dev-python/scikit-build-core/Manifest
@@ -1,5 +1,7 @@
DIST scikit_build_core-0.7.0.tar.gz 197884 BLAKE2B f632cc131af9db03db2c84b32e451c6369273f9d5db0bca2991cface419c5f9faa5d98239a8a5edd8a36749bc368c0f3c25b3813f33ed63f125731ba4e3d11ae SHA512 ee50070156030fe6c8e07db428902bec67e2267bf36338e62bd936e63f402da869fc4c629c0bc274ab6f798642d163906cc8d6695a62228580ba979878e5d6f8
DIST scikit_build_core-0.7.1.tar.gz 197949 BLAKE2B bcce5c5f71ce1417e5912d9c60c1f1c8bd656feb16b255e7d94f8fe49f75354c940a940fedd07f9c03b200c8858e24537686067463a47699e9285178e64f32f8 SHA512 30b479708b2265789ad4d43ab0ef8a433cf6745223b9812e95b0e45356ab9ad0689ee8f546f3c3af0bd482342d5518d381481b58480b715023c6baa87235952a
+DIST scikit_build_core-0.8.0.tar.gz 202019 BLAKE2B 92eded3ca562cb3089502cdf017e33ceca6a816e8ee73a62e780a7c291b4606710598fb357585fcfb83362bd5c4275d31b602ad7243aadce94a78bcae1ae5cd3 SHA512 82a20d54a699403ce97e71b95288935e5f0fb3ebafa897d9620612727d4aee5a003384e65665b002b1f2db2b0672d9b05c0428d26f00bc5300cbd884cef6e519
EBUILD scikit-build-core-0.7.0.ebuild 1393 BLAKE2B 74d34c358667057443318e92347bd7992d5f64cc92c30e2a4566565fe739c8ba1cf2141fc57dbbec713990d734f895ab84514616f92d5921f22d29c313982692 SHA512 ae1f2ee40e011c683a1e7a478cadcd01b1ff20b0d5097f670f9732818288a42307e4407d701b68943249b8a76a500d321207b0e372d45d98c7afe11fbf1488c9
EBUILD scikit-build-core-0.7.1.ebuild 1455 BLAKE2B de01bed5cf6c16abb5fa9eb55a5f0b0056e79ea2181bb85bdff0f4b507229443332e0b01233e110f08bf4c3a9eb9c89989e92bffda64f2809803c495a57f6776 SHA512 9240195ba041e55a52f04072e0c0930c7cb606479a5453a67267ac3b3ac41151f42c2248e596a08017668404cb6e737d7e514e83294cc5b6a97be1fd3faa7172
+EBUILD scikit-build-core-0.8.0.ebuild 1455 BLAKE2B de01bed5cf6c16abb5fa9eb55a5f0b0056e79ea2181bb85bdff0f4b507229443332e0b01233e110f08bf4c3a9eb9c89989e92bffda64f2809803c495a57f6776 SHA512 9240195ba041e55a52f04072e0c0930c7cb606479a5453a67267ac3b3ac41151f42c2248e596a08017668404cb6e737d7e514e83294cc5b6a97be1fd3faa7172
MISC metadata.xml 393 BLAKE2B 25bdc0bc295ed4bd7cd76a5a6952cb7fa5d5a404d3260562f2ed322d80f2466add0373a2a6b10a41c4dc2211e82e0a680735301d8844e70a54760301b4ab190f SHA512 176537f2027aedb3bc8bd16bbbcde8bfed246d621763e22a979f2942c016e1bafa5ef2d11d8d078e5d59970ea115864a8501185343bc3d4b9fd8493adbd16aab
diff --git a/dev-python/scikit-build-core/scikit-build-core-0.8.0.ebuild b/dev-python/scikit-build-core/scikit-build-core-0.8.0.ebuild
new file mode 100644
index 000000000000..d49a764ca1e3
--- /dev/null
+++ b/dev-python/scikit-build-core/scikit-build-core-0.8.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Build backend for CMake based projects"
+HOMEPAGE="
+ https://github.com/scikit-build/scikit-build-core/
+ https://pypi.org/project/scikit-build-core/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# we always want [pyproject] extra
+RDEPEND="
+ >=dev-python/packaging-20.9[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-metadata-0.5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.1[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ >=dev-python/cattrs-22.2.0[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ >=dev-python/pytest-subprocess-1.5[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO / we don't package validate_pyproject anyway
+ tests/test_schema.py::test_compare_schemas
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p subprocess -m "not isolated and not network"
+}