summaryrefslogtreecommitdiff
path: root/dev-python/scientificpython/scientificpython-2.9.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/scientificpython/scientificpython-2.9.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/scientificpython/scientificpython-2.9.4.ebuild')
-rw-r--r--dev-python/scientificpython/scientificpython-2.9.4.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/scientificpython/scientificpython-2.9.4.ebuild b/dev-python/scientificpython/scientificpython-2.9.4.ebuild
new file mode 100644
index 000000000000..a760b97ee758
--- /dev/null
+++ b/dev-python/scientificpython/scientificpython-2.9.4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="ScientificPython"
+MY_P="${MY_PN}-${PV}"
+DOWNLOAD_NUMBER=4570
+
+DESCRIPTION="Scientific Module for Python"
+SRC_URI="http://sourcesup.cru.fr/frs/download.php/${DOWNLOAD_NUMBER}/${MY_P}.tar.gz"
+HOMEPAGE="http://sourcesup.cru.fr/projects/scientific-py/"
+
+LICENSE="CeCILL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc mpi test"
+
+RDEPEND="
+ <dev-python/numpy-1.9[${PYTHON_USEDEP}]
+ dev-python/pyro:3[${PYTHON_USEDEP}]
+ sci-libs/netcdf
+ mpi? ( virtual/mpi )"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.9-mpi.patch )
+DOCS=( README README.MPI Doc/CHANGELOG Examples/demomodule.c Examples/netcdf_demo.py )
+
+python_prepare_all() {
+ use mpi && PATCHES+=( "${FILESDIR}"/${PN}-2.9.3-mpi-netcdf.patch )
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+ if use mpi; then
+ cd Src/MPI || die
+ ${PYTHON} compile.py || die
+ mv -f mpipython mpipython-${EPYTHON} || die
+ fi
+}
+
+python_test() {
+ cd "${S}"/Tests || die
+ nosetests -v -v || die
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ if use mpi; then
+ cd Src/MPI || die
+ python_newexe mpipython-${EPYTHON} mpipython
+ fi
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( Doc/Reference/. )
+ use mpi && EXAMPLES=( Examples/mpi.py )
+ distutils-r1_python_install_all
+}