summaryrefslogtreecommitdiff
path: root/dev-python/scandir
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/scandir
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/scandir')
-rw-r--r--dev-python/scandir/Manifest5
-rw-r--r--dev-python/scandir/metadata.xml16
-rw-r--r--dev-python/scandir/scandir-1.6.ebuild23
-rw-r--r--dev-python/scandir/scandir-1.7.ebuild23
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/scandir/Manifest b/dev-python/scandir/Manifest
new file mode 100644
index 000000000000..df0bd3753fd5
--- /dev/null
+++ b/dev-python/scandir/Manifest
@@ -0,0 +1,5 @@
+DIST scandir-1.6.tar.gz 29670 BLAKE2B ad8c231783c14246341cd23bd79185ee10894bb29107ba7c0bfdf51982bda99fd8ce45ea52ff42687371d56b3e6d43cf1d6cc65bdaecf43da9059e524a801e6d SHA512 d01e0551696787caded787a430eea787a69a27c725505277420fd607b3fcc892218377bb340651fd906bdeb3a57e99879df3c86aeadd2399fcbe45cb2118b9db
+DIST scandir-1.7.tar.gz 32812 BLAKE2B ed80775b5acca85d8829e2fb46df33fdda08d9dad6cc0e175d1270dc51b6eb4d381a5bd813e2dfd2072ac0af0d642d20ae818e569688ffbe5decaf4421f5e979 SHA512 47c6d9642938f374eb03228cdb6c8d77aa2af01a84b7efc518d223851562a615b616e92100bbeb38c4fa7455ef5f7ae4af8d406f5148d1a26a403708b4a27023
+EBUILD scandir-1.6.ebuild 558 BLAKE2B efcfb1c039107ed40ffe1939bd391b068cdf8149bc732a1c43fedba488ef284509501d1160a3d73268d69ac5a99f6ff14891c6ebbd95143e814f8cae64ca6043 SHA512 95d06232bab59651fca2bc25dd7b4d8f21dbc72cc3b41b84dd5585987853f26d72a132131e0a07638690e348573a809f2ccc3d61009a6d46f83e7154deca880f
+EBUILD scandir-1.7.ebuild 565 BLAKE2B 9d08fb18c8277903a9d1f2e38a2d5da42c095ff3c9c4e9919fd23c408d64156651188feed20df5cc03569419e8c1372f0e3653fac168e5b3de85ab0cb572ce28 SHA512 f46a08f4858fdabcdf8b0221b956aa589bffe1c0c82d16540ca1efccb4dd2925abbb3ef57a5a5a53f551023cca7abb8d17d3b630a1c61d1467de0b1cb7cdd528
+MISC metadata.xml 495 BLAKE2B 7137cdfc395a1e80576885adb3c870ba25034a657c342b3819328f276d55ebf6d7756e57644a6ff4d45ca07cdb561078dbb1deb1b993816c7088850dee45c3bb SHA512 e762fa761b5b00288870eac3af8aed0d05efba207d83138adc873da902a7e197b710caeb87a3083e5f23436f4a2c799996fe07201195de065bd430b9c35183ee
diff --git a/dev-python/scandir/metadata.xml b/dev-python/scandir/metadata.xml
new file mode 100644
index 000000000000..ddb3745e14bd
--- /dev/null
+++ b/dev-python/scandir/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ <name>Patrice Clement</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">scandir</remote-id>
+ <remote-id type="github">benhoyt/scandir</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/scandir/scandir-1.6.ebuild b/dev-python/scandir/scandir-1.6.ebuild
new file mode 100644
index 000000000000..eee1a9dbdbf3
--- /dev/null
+++ b/dev-python/scandir/scandir-1.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A better directory iterator and faster os.walk()"
+HOMEPAGE="https://github.com/benhoyt/scandir"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ppc64 x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} test/run_tests.py -v || die "tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/scandir/scandir-1.7.ebuild b/dev-python/scandir/scandir-1.7.ebuild
new file mode 100644
index 000000000000..ca8fa0e8d051
--- /dev/null
+++ b/dev-python/scandir/scandir-1.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A better directory iterator and faster os.walk()"
+HOMEPAGE="https://github.com/benhoyt/scandir"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} test/run_tests.py -v || die "tests failed under ${EPYTHON}"
+}