summaryrefslogtreecommitdiff
path: root/dev-python/sarif-om/sarif-om-1.0.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-25 14:40:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-25 14:40:37 +0100
commit2000f81da4dc9971f6e1e5d00b315816d4188f4c (patch)
tree479704e6bf1eeba3c58172680d8bc26b87c71e68 /dev-python/sarif-om/sarif-om-1.0.4-r1.ebuild
parent6d57946e8f20a2294b96eca2e379d3e8e1c93384 (diff)
gentoo auto-resync : 25:10:2023 - 14:40:37
Diffstat (limited to 'dev-python/sarif-om/sarif-om-1.0.4-r1.ebuild')
-rw-r--r--dev-python/sarif-om/sarif-om-1.0.4-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/sarif-om/sarif-om-1.0.4-r1.ebuild b/dev-python/sarif-om/sarif-om-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..8cb36b16739f
--- /dev/null
+++ b/dev-python/sarif-om/sarif-om-1.0.4-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Classes implementing the SARIF 2.1.0 object model"
+HOMEPAGE="
+ https://pypi.org/project/sarif-om/
+ https://github.com/microsoft/sarif-python-om/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]"