summaryrefslogtreecommitdiff
path: root/dev-python/sancho
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/sancho
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/sancho')
-rw-r--r--dev-python/sancho/Manifest3
-rw-r--r--dev-python/sancho/metadata.xml11
-rw-r--r--dev-python/sancho/sancho-2.4-r1.ebuild43
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/sancho/Manifest b/dev-python/sancho/Manifest
new file mode 100644
index 000000000000..1d82060cc0a9
--- /dev/null
+++ b/dev-python/sancho/Manifest
@@ -0,0 +1,3 @@
+DIST Sancho-2.4.tar.gz 7962 BLAKE2B 10e57286834276c6ca37638f4e550d676f5a31f2fa7fb567dfcceb492111c92ffa5aa313886f1d0803048f612aad905f0fd4ebcbcb41838942af083ea1dec2c7 SHA512 49230ee8a05dbc5bf3d7b3900504f47a3a47f013878e75f93c277610e4d22f9714b9a58a41a779e25b0ddb9c24ff351508c0b72c78fe146b8371024345629e21
+EBUILD sancho-2.4-r1.ebuild 1078 BLAKE2B ccf4104ab78a38dba0a064c442123a5c2697977003d14bae6c1d4b1c4c0a697fc4ae746f8d6f4a1d6eac067bc9173f1c8d8a630bd5f7cbdac295ddf9168459ba SHA512 60e44923fee2028ce42616e6959c785fa2aebf1bf196b60ba2f0f66175cab2ea885afc79192f9332a4e8043f84cf57643c9daf79c7f8cbf627ada6e5561dd8c4
+MISC metadata.xml 312 BLAKE2B 99dcf5669889a8657e61ef5d89d2f7a34b29d4b5454f078537085e8a44456a2d26a0d8407ea66a796ba76c36d21f64d9e1ac85a6076abfbe9ceefc6d40a70479 SHA512 088e74f48915eaf8bab9d7a17ba2f4ffa4696b6c93ec291c13406f48665b344dae925cc46468c9d99523eaa848c0aa6fef54bf6a7bee752f4fadbe149bcda59f
diff --git a/dev-python/sancho/metadata.xml b/dev-python/sancho/metadata.xml
new file mode 100644
index 000000000000..9cbbcb5053ac
--- /dev/null
+++ b/dev-python/sancho/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+<maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-python/sancho/sancho-2.4-r1.ebuild b/dev-python/sancho/sancho-2.4-r1.ebuild
new file mode 100644
index 000000000000..38d99a97417d
--- /dev/null
+++ b/dev-python/sancho/sancho-2.4-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_P="Sancho-${PV}"
+
+DESCRIPTION="Sancho is a unit testing framework"
+HOMEPAGE="https://www.mems-exchange.org/software/sancho/"
+SRC_URI="https://www.mems-exchange.org/software/files/${PN}/${MY_P}.tar.gz"
+
+LICENSE="CNRI"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ cd test
+ local test test_failure test_failure_count=0
+ for test in *.py; do
+ test_failure="0"
+ ebegin "Testing ${test}"
+ "${PYTHON}" "${test}" > "${test}.output"
+ grep -Eqv "^${test}: .*:$" "${test}.output" && test_failure="1"
+ eend "${test_failure}"
+ if [[ "${test_failure}" == "1" ]]; then
+ ((test_failure_count++))
+ eerror "Failure output for ${test}"
+ cat "${test}.output"
+ fi
+ done
+ if [[ "${test_failure_count}" -gt "0" ]]; then
+ die "${test_failure_count} tests failed"
+ fi
+}